Author Topic: raspberry pi 2  (Read 29057 times)

nitrogen_widget

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
Re: raspberry pi 2
« Reply #15 on: March 22, 2015, 04:20:53 PM »
I re-download ed the source before I compiled so that bypasses the need to make clean right?

raygun

  • Administrator
  • Sr. Member
  • *****
  • Posts: 393
    • View Profile
Re: raspberry pi 2
« Reply #16 on: March 23, 2015, 10:41:01 PM »
My guess is that you have an older version of SFML's libraries (2.1 perhaps) somewhere in your library path and it is trying to link against that old version rather than the new one.


Your linker isn't finding sf::Image::~Image... this function exists in the most recent SFML that my changes are based on but it looks like it is relatively recent and didn't exist in earlier SFML versions.


nitrogen_widget

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
Re: raspberry pi 2
« Reply #17 on: March 24, 2015, 04:01:52 AM »
Whoops.
Still had sfml from the repo's installed.
after i removed that it compiled just fine.
Runs smooth in the menu's

i'll test video's and a theme with wheel art tonight since i need to go to work now.

I do get this message spammed in the terminal window:

Quote
sf::Quads primitive type is not supported on OpenGL ES platforms, drawing skipped

but it doesn't appear to be critical.
« Last Edit: March 24, 2015, 04:05:38 AM by nitrogen_widget »

JDGJr

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: raspberry pi 2
« Reply #18 on: March 24, 2015, 07:45:05 PM »
I'm eagerly awaiting your report as I'd love to use this for a demo. Thanks for your effort!

nitrogen_widget

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
Re: raspberry pi 2
« Reply #19 on: March 25, 2015, 04:01:57 AM »
so i somehow hosed my sdcard last night.
but, i just got my class10 card in so I re-flashed raspbian, re-compiled everything including advmame .94 and attract plays videos at a good speed.
However, the whole emulator looks wrong.
like it's using 8 bit color and I have no sound not only on my videos but advmame won't luanch either.
terminal shows "can't decode audio" error for advmame.

calling roms with just advmame works fine.

i made a video so you can see what i'm getting.
https://www.youtube.com/watch?v=LUL_2EASsZ8

I probably missed some dependency when compiling or something.

nitrogen_widget

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
Re: raspberry pi 2
« Reply #20 on: March 25, 2015, 06:07:14 AM »
I was thinking about the image quality and how I didn't have it on my first raspbian install and I don't believe I changed my video memory split.
Last time I had 256 MB dedicated to video.
Now I think I have only 64 or 128 mb.
So I'll change that when I get home tonight and see if it makes a difference.

EDIT: I changed my video ram to 256 and that got rid of the sf::Quads primitive type is not supported on OpenGL ES platforms, drawing skipped error.
But I still get the audio decode error when AM pulls up a video or launches a game.
I also still get the slight screen corruption.

However, OMX player plays my preview avi's perfectly.

This is what I get when I run attractmode then try to play a game.

Quote
attract
Starting Attract-Mode 1.5.1 (Linux)
Config: /home/pi/.attract/attract.cfg

*** Initializing display: 'mame'
 - Loaded master romlist 'mame' in 6 ms (173 entries kept, 0 discarded)
 - Constructed 2 filters in 4 ms (346 comparisons)
Failed to set the window's icon: Error code 16
 - Loaded layout: /home/pi/.attract/layouts/reflect/ (layout.nut)
Error decoding audio.
Error decoding audio.
Error decoding audio.
Error decoding audio.
Error decoding audio.
Error decoding audio.
Error decoding audio.
Error decoding audio.
*** Running: /usr/local/bin/advmame journey
AdvanceMAME - Copyright (C) 1999-2003 by Andrea Mazzoleni
MAME - Copyright (C) 1997-2003 by Nicola Salmoria and the MAME Team
Error decoding audio.
Error decoding audio.

any ideas?
« Last Edit: March 25, 2015, 05:03:51 PM by nitrogen_widget »

nitrogen_widget

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
Re: raspberry pi 2
« Reply #21 on: March 26, 2015, 04:11:10 PM »
ok.
Fixed the display by adding:
framebuffer_depth=32
framebuffer_ignore_alpha=1

to the config file in the boot folder so now everything looks good.

still getting that issue with error decoding audio when I pick a video or try to launch a Rom with advmame (which works from command prompt)
so i'll keep digging.

Edit: turns out some of my video's have an audio format my whole RPI 2 doesn't like.
I can't play the majority of my game avi's audio with mplayer or VLC.

so that issue is resolved also.
I found the default screen mode "fillscreen" doesn't work when it comes to launching roms on advmame.
Fullscreen works.

so the only new issue I have is I changed my screen resolution to 1280x720 from some oddball resolution and while mame runs better attractmode is now only occupying the bottom left corner of my screen & also runs off the screen.

so I need to play with that now.

almost there. :)
« Last Edit: March 26, 2015, 06:04:04 PM by nitrogen_widget »

raygun

  • Administrator
  • Sr. Member
  • *****
  • Posts: 393
    • View Profile
Re: raspberry pi 2
« Reply #22 on: March 27, 2015, 10:23:24 PM »
great, thanks for the updates nitrogen... I've got a collection of fixes for the raspberry pi that I'm putting together based on your feedback.  I think I'll also have it hardcode fullscreen mode when running on the pi.

nitrogen_widget

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
Re: raspberry pi 2
« Reply #23 on: March 28, 2015, 08:15:07 AM »
Great.
AM may end up being the only active rpi front end with legit vertical support.

FYI if you hadn't noticed I tend to ramble when trouble shooting a problem.
I'm worse at work. Lol.

softserve

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: raspberry pi 2
« Reply #24 on: June 12, 2015, 06:32:58 AM »
First of all, thanks for all of the information. It's taken a lot of work, but I have Jessie installed and was able to get through most of the process listed on the mickelson site.

I've gotten to the point where I've downloaded attract. I can't seem to get the 'make' command to work though and keep getting this error. I just cannot for the life of me figure out what it wants.

Quote
root@jessie-rpi:~/develop/attract# make
g++ -c -o obj/fe_base.o src/fe_base.cpp  -DDATA_PATH=\"/usr/local/share/attract/\" -O2 -s -Iextlibs/audio/include -I/usr/include/freetype2 -I/usr/include/AL  -Iextlibs/squirrel/include -Iextlibs/sqrat/include  -DUSE_FONTCONFIG -DUSE_AVRESAMPLE
In file included from src/fe_base.cpp:24:0:
src/fe_util.hpp:28:27: fatal error: SFML/Config.hpp: No such file or directory
 #include <SFML/Config.hpp>
                           ^
compilation terminated.
Makefile:290: recipe for target 'obj/fe_base.o' failed
make: *** [obj/fe_base.o] Error 1

Thanks for any help

verion

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 861
    • View Profile
    • new projects
Re: raspberry pi 2
« Reply #25 on: June 12, 2015, 09:04:29 AM »
Can I run GLSL shaders on RPi?

nitrogen_widget

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
Re: raspberry pi 2
« Reply #26 on: June 12, 2015, 11:10:04 AM »
Can I run GLSL shaders on RPi?

maybe?
libretro mame4all should let you use shader's.
there is a great thread on the retropi forum.
just search for shader.

with mame & xwindows you are pretty much stuck with mame4all or advmame in overlay mode with the lowest possible resolution because sdl1 is not hardware accelerated under xwindows.
This means all scaling is done in software.

robertybob

  • Jr. Member
  • **
  • Posts: 14
    • View Profile
Re: raspberry pi 2
« Reply #27 on: February 25, 2016, 05:35:15 PM »
Sorry to bump a really old thread, but I thought I would try to compile Attract from source (just for the fun of it really). I am, however, having real difficulties doing so, on both Jessie and Wheezy.

Following the Wiki instructions https://github.com/mickelson/attract/wiki/Compiling-on-the-Raspberry-Pi-%28Raspbian-Wheezy%29

and everything is fine until I get to:

Code: [Select]
~/develop $ cd attract
~/develop/attract $ make

it says:

Quote
fatal:No names found, cannot describe anything

It then proceeds to build, or do something..

when I do the next step
Code: [Select]
~/develop/attract $ sudo make install
I get:

Quote
fatal: No names found, cannot describe anything.
install -D -t /usr/local/bin attract
mkdir -p /usr/local/share/attract/
cp -r config/* /usr/local/share/attract/


then when I run "Attract" it says:


Quote
Starting Attract-Mode v2.0.0 (Linux)
Config file not found: /home/pi/.attract/attract.cfg, performing initial setup.
Failed to open X11 display; make sure the DISPLAY environment variable is set correctly
Aborted


I have tried compiling on both Wheezy and Jessie and yet I get the same errors, can anyone help?

nitrogen_widget

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
Re: raspberry pi 2
« Reply #28 on: February 26, 2016, 11:17:44 AM »
did you compile SFML first?
did you install all depends?

Are you in X when you compile?

robertybob

  • Jr. Member
  • **
  • Posts: 14
    • View Profile
Re: raspberry pi 2
« Reply #29 on: February 26, 2016, 12:00:11 PM »
did you compile SFML first?
did you install all depends?

Are you in X when you compile?


Yes, SFML seemed to compile ok. Dependencies were ok (had to add one to the Wiki mind you).

I'm compiling via SSH, am I supposed to do it when on the X desktop?