Author Topic: Tool to show assets and info completion statistics like snaps, flyers, genres...  (Read 4576 times)

farique

  • Full Member
  • ***
  • Posts: 28
    • View Profile
Attract Mode List Statistics

*Update3 (v1.3):

- Attract Mode 2.3 and 2.4 overviews support

- Much smarter emulator config parser works with and without a Working Directory and can understand $HOME, $PROGDIR, %SYSTEMROOT% and %PROGRAMFILES%

- Extended image extensions now finds .jpg . jpeg .png .gif .bmp and .tga files

- Cannot deal with <DIR> rom extensions for now.

---

Hi,
To help me organize the mess of material I have gathered over more than a decade, I build an Autoit script (with GUI) that looks into the assets (snaps, covers, etc) I have and gives me statistics on each system I use on Attract Mode.

It ends up being a lot of help finding missing and surplus material buried on the assets folders as well as missing game information (year, publishers and genre.)

I don´t know how big of a problem this is to the rest of you, but the systems I have are not always the most popular ones (TRS Color, for instance) so I have some problem collecting extra stuff. More than a decade of gathering material from all over the webs and the fact that the scrapers do not (at least for me) do a wonderful job also do not help, so I thought the need to see the big picture at one place would be nice.

I compiled and polished the thing a little and I think it is ready to be used on the outside world.
Unfortunately, I think it only works on Attract Mode v2.3 I still haven’t v2.4 installed.

That is it. If you try it, please tell me what you think.

New version, MUCH faster scanning, down from ~5 min on my ~8k roms (across all systems) to ~13sec!!

You only need to replace the .exe if you are already using it.
May need a rescan to build new support files.
« Last Edit: August 22, 2018, 09:38:26 AM by farique »

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1167
    • View Profile
Very cool! I can’t wait to try it! Similar idea to the tool I just released last week, but a different approach that has me thinking about thinks other people might need!

farique

  • Full Member
  • ***
  • Posts: 28
    • View Profile
Thanks, hope it works for you.

And yes, before I developed a complex but sure workflow (you should see my Excels) and learned to code my own tools, I looked for every tool I could find that could help minimize the mess that is to try to tame these old sets.

That is why I made the extra effort to try to polish this one, hoping it might be useful to someone else.

There are more where this came from :-) simpler ones. I'll post them but I think I need to upgrade them to v2.4 before doing so. What do you think?

jedione

  • Hero Member
  • *****
  • Posts: 1106
  • punktoe
    • View Profile
dam, this is cool....just tryed on a 2.3 set up    works great!  thank you
this is a great colectors tool.

love how you can see overviews you have and still need.. :)

probaley will need a revamp for 2.4 because of the location and extention change

thank you
help a friend....

farique

  • Full Member
  • ***
  • Posts: 28
    • View Profile
Hi people,

Updated the program and it is MUCH faster now.
Down from ~5min to ~13sec scanning all my ~8k roms.
The lists also should take almost no time to generate.

Enjoy and if you catch any bugs, let me know.

ryuuji

  • Sr. Member
  • ****
  • Posts: 109
    • View Profile
tried it today but it shows that I have only 4 roms (none of which are correct because they are on a different location: local disk(d) and they are not even mame roms or any roms at all). I do have a up to date mame set.

farique

  • Full Member
  • ***
  • Posts: 28
    • View Profile
tried it today but it shows that I have only 4 roms (none of which are correct because they are on a different location: local disk(d) and they are not even mame roms or any roms at all). I do have a up to date mame set.

* EDIT: Think I found it. AMLS is not programmed to look into variables such as $HOME or $PROGDIR. Would generate a problem consistent with yours. Working in a a solution.

And that is why smart people code log files.
Thanks for the feedback. Let's do it the hard way then.
(starting with the stupid questions)

- Are you using AM 2.3 or 2.4? It should work fine on 2.4 (apart from not finding the overviews) but I just copied all my config files over from 2.3 and so might be missing something.

- You had to click and find your AM path, right?  I mistakenly sent this copy with my AM path on the configuration, it should't be a problem as yours are probably different anyway, but mine is very generic, so...

- Are there anything unusual on your roms and assets paths that may be confusing for a dumb program?

- When you click on "Sys config info" (top right) does it shows the correct information and paths. Can you post it so I can see?

That is all I can think for now.

[starts working a log output]
« Last Edit: August 21, 2018, 03:09:46 PM by farique »

ryuuji

  • Sr. Member
  • ****
  • Posts: 109
    • View Profile
AM 2.4 selected AM path and the results:
attached the mame.cfg also

farique

  • Full Member
  • ***
  • Posts: 28
    • View Profile
AM 2.4 selected AM path and the results:
attached the mame.cfg also

Found the problem. Turns out the configuration loading algorithm is a complete mess!
It is totally dependent upon MY kind of setup and expects a Working Directory and, as I sai above, cannot deal with $HOME and the like.
A lot of the people must be having problems, tanks for the report.

I am working on a solution and will post soon.

farique

  • Full Member
  • ***
  • Posts: 28
    • View Profile
Think I've solved the problem, ryuuji. It is working with your mame.cfg.
Should work with most setups now.
v1.3 on original post.

jedione

  • Hero Member
  • *****
  • Posts: 1106
  • punktoe
    • View Profile
Think I've solved the problem, ryuuji. It is working with your mame.cfg.
Should work with most setups now.
v1.3 on original post.

this is great to here... and thanks for you work
will try soon..
help a friend....

ryuuji

  • Sr. Member
  • ****
  • Posts: 109
    • View Profile
Think I've solved the problem, ryuuji. It is working with your mame.cfg.
Should work with most setups now.
v1.3 on original post.

Now u got it ... works as it should

disguisedcoot

  • Newbie
  • *
  • Posts: 1
    • View Profile
Is this only for the windows build of AM?

farique

  • Full Member
  • ***
  • Posts: 28
    • View Profile
Is this only for the windows build of AM?

It will only run on Windows and it uses the emulator configuration files and romlists of Attract Mode to get the paths and info it needs.

It will pull the assets paths from the emulators config and use them to look for the files, so they probably have to be on the same machine (the same absolute path must work for both)

If your setup (asset files) are INSIDE the AM path and depending on how you access it through Windows (mapped drive?), it might work. It might also work for the information on the romlists (Year, Publisher and Manufacturer) and the Overviews as they are on the same relative path as Attract Mode.

I have no way of testing, tho.