Recent Posts

Pages: [1] 2 3 ... 10
General / Need to move layout UP
« Last post by Kaizen777 on Yesterday at 12:13:40 PM »
Hello!  Does anybody know a way to move/offset a layout vertically?
I have a 16:9 TV rotated vertically (portrait) orientation in my arcade cab.
About 40% of the screen is hidden (in the marquee area and below the control panel)
My problem is that the visible area of my screen is not centered on the TV, and attractmode appears to automatically center the layout vertically.
I need to be able to vertically offset layouts in order to view them correctly. (move them up)
Is there a way to do this?
Thank you!!  :)
General / Re: Windows .bat files wont load in Attract Mode
« Last post by Retrozz on Yesterday at 05:28:17 AM »
I hope this helps the OP.. this works 100% and a lot less messing around..

executable           $PROGDIR\Start_Emu.bat
args                 "[romfilename]" stella_libretro.dll at2600
rompath              $PROGDIR\roms
romext               .a26;.zip
system               a2600;Atari 2600
info_source          listsoftware
artwork    flyer           $PROGDIR/extras/boxart
artwork    marquee         
artwork    snap            $PROGDIR/extras/videos
artwork    wheel           

for completeness.. near the start of my 'universal loader' batch (currently rewriting to a windows executable instead, but meanwhile...)

rem clear variables we are using
set game_file=
set core_name=
set emu_name=

rem check if user forgot to pass parameter
if [%1] == [] goto bad_filename
if [%2] == [] goto bad_filename
if [%3] == [] goto bad_filename

echo filename passed along was: %1 >>last_game_played.txt
set game_file=%1%

echo code name passed along was: %2 >>last_game_played.txt
set core_name=%2%

echo emulator name passed along was %3 >>last_game_played.txt
set emu_name=%3%

rem front end keeps putting / in filename!!!!! Let's fix that..
set game_file=%game_file:/=\%

**note that last line above.. AM puts / instead of windows/dos \ **
You probably moved artwork media in a place that's different from the one in the emulator .cfg file:
Like the title says.

I was streamlining my laptop for mame and attract mode to run the best along with moving files to a better centralized location. and after moving videosnaps, and adding correct path, they no longer work.

So i was wondering if i shut off a certain program needed to run videosnaps or something else is going on?

thanks in advance,
Themes / Re: Arcadeflow theme v 16.0 [Release] Updated 05 June 2023
« Last post by zpaolo11x on June 05, 2023, 12:00:11 AM »
Arcadeflow 16.0 is out!

For this version that has an evocative number, a lot of code has been refactored to be more robust and efficient. Lots of new features under the hood but also a new menu look.

## What's new in v 16.0 #

- Added option for fullscreen tiles
- Added option for scrape timeout
- Added new zoom rate options
- Redesigned help images for options
- Improved More of the Same menu
- Improved support for multi emulator romlists
- Fixed bug with More of the Same menu
- Fixed zoom ratio for slimline layout
- Fixed support of redirect romlists

Emulators / Trouble closing TeknoParrot
« Last post by wsprs0 on May 29, 2023, 08:31:41 AM »
Hey all, I have AM working fine to launch TeknoParrot games, but closing them seems to cause me trouble.

I have tried several methods that others have used here to launch the games. I have tried to shortcut method, and I have tried to method of directly launching the TPUI exe with the arguments attached.

Both methods result in the same kind of buggy close. The game WILL close (via TP's escape button) but AM will come back to a completely blank screen until I jiggle a controller or button.

After that, nothing will launch again, it will either try to launch and then immediately close, or try to launch and hang at a blank screen. Whether it's the same game or a new game. It only seems to resolve if I completely close down AM (or restart the PC).

Anyone else running into any similar trouble? Anyone know what I might be able to do there?


Additional info if it helps:

AM version: 2.6.1 (I see 2.6.2 available, and plenty of commits since then, can check those out?)
Windows version: 11 22H2 OS build 22621.1702
TeknoParrot version: Latest everything as of this writing


Ah well... ended up moving to LaunchBox/Big Box... everything works over there.
Themes / Re: Old memories Theme/Layout - v1.0 downloadable
« Last post by Lukesv on May 28, 2023, 01:07:37 AM »
Hi, very nice layout but the download link doesn't seem to work.
Scripting / Re: PDF Manual plugin.. please helphere.. just one dobout...
« Last post by gamesmame on May 26, 2023, 07:44:42 AM »
for example, read cbr and pdf with no choose, but automatic.. :P
Scripting / PDF Manual plugin.. please helphere.. just one dobout...
« Last post by gamesmame on May 26, 2023, 06:27:13 AM »
How i make the sumatra read all formats with no need change options!!! have this way?!!! have this way?


Code: [Select]
// Attract-Mode Frontend - SumatraPDF  WIP plugin (By Machiminax)
// For use with the SumatraPDF Reader

// The UserConfig class identifies plugin settings that can be configured
// from Attract-Mode's configuration menu
class UserConfig </ help="Read your Manuals with SumatraPDF" /> {

    </ label="Command", help="SumatraPDF launcher", order=1 />
    </ label="Extension", help="File extension to use", options=".pdf, .chm, .djvu, .djv, .epub, .fb2,, .mobi, .prc, .oxps, .xps, .cb7, .cbr, .cbt, .cbz", order = 2 />
    </ label="Path", help="Path to manuals - can include [Name], [Emulator], [Year], [Manufacturer], [System], [DisplayName]", order = 3 />
    path="Game Manuals/[Emulator]";
    </ label="View Key", help="Key to use to view", options="custom1,custom2,custom3,custom4,custom5,custom6", order = 4 />
    </ label="Missing Image", help="Path to 'missing' image - can include [Name], [Emulator], [Year], [Manufacturer], [System], [DisplayName]", order = 5 />

local config=fe.get_config(); // get user config settings corresponding to the UserConfig class above

// Copy the configured values from uconfig so we can use them
// whenever the transition callback function gets called

class PDFManualReader

        fe.add_signal_handler( this, "on_signal" )

    function on_signal( signal )
            if ( signal == config["key"] )
                local path = get_magic_token_path(config["path"]);
                local game_name = fe.game_info(Info.Name);
                local filename = "\"" + path + game_name + config["extension"] + "\"";
                local missing_path = get_magic_token_path(config["missing"]);
                local missing = "\"" + missing_path.slice(0, missing_path.len() - 1) + "\"";
                local exe = FeConfigDirectory  + "/plugins/SumatraPDF/" + config["command"];
                print("Launching SumatraPDF:\n");
                print(" " + exe + " " + filename + " " + missing + "\n");
                fe.plugin_command_bg( exe, filename + " " + missing );
                return true;
            return false;
    //replace specified magic tokens in path
    function get_magic_token_path(path) {
        local tokens = {
            "Name": fe.game_info(Info.Name),
            "Emulator": fe.game_info(Info.Emulator),
            "Year": fe.game_info(Info.Year),
            "Manufacturer": fe.game_info(Info.Manufacturer),
            "Category": fe.game_info(Info.Category),
            "System": fe.game_info(Info.System),
        foreach( key, val in tokens)
            path = replace(path, "[" + key + "]", val);
        //replace slashes with backslashes
        path = replace(path, "\\", "/");
        //ensure trailing slash
        local trailing = path.slice(path.len() - 1, path.len());
        if ( trailing != "/") path += "/";
        return path;
    //replace all instances of 'find' in 'str' with 'repl'
    function replace(str, find, repl) {
        local start = str.find(find);
        if ( start != null ) {
            local end = start + find.len();
            local before = str.slice(0, start);
            local after = str.slice(end, str.len());
            str = before + repl + after;
            str = replace(str, find, repl);
        return str;

I have a problem, I read the posts and followed the guide, I put the videos in the folder called themes and the wheels in the menu-art folder, I see the videos but I don't see the wheels, why????I ask for help
did you make sure you made a folder for it and also give a right path for it ? can you show us your arg text for it as well ?
Pages: [1] 2 3 ... 10