Author Topic: Picture not found attract FREEZES  (Read 464 times)

the_gamer

  • Newbie
  • *
  • Posts: 7
    • View Profile
Picture not found attract FREEZES
« on: May 10, 2018, 10:21:56 AM »
Hi there,

what image does attract show when an image for a game is not found? The point is that my attract
freezes whenever a screenshot/snap of a game is not found and I need to solve this, attract must
not freeze and not because of that. So what picture is shown/how to select it?

Greetings

[Update] This only seems to happen on mame emulator. In other emulators a yellow screen with attract on it is shown. Why does it freeze in mame and not show the picture? Giving it any picture solves the freeze but i really would like to solve the problem![/Update]

Error does not happen in attract-2.1.0 but 2.3.0.r44(newest git-version freezes. So what is wrong here?
« Last Edit: May 10, 2018, 11:18:45 AM by the_gamer »

progets

  • Hero Member
  • *****
  • Posts: 604
    • View Profile
Re: Picture not found attract FREEZES
« Reply #1 on: May 11, 2018, 10:50:15 PM »
First, try using the "Basic" layout to see if it has the same issue. If it doesn't your problem might be specific to the layout you're using (which you didn't tell us).

If you aren't using the AM console version, you can download and run the AM 2.3.0 console version to see what errors are logged on the screen. To do this you can simply download it, extract it somewhere temporary, rename attract.exe to attract-console.exe, and move attract-console.exe into your existing AM folder. Then you can run attract-console.exe from the command line and you will see any errors that happen.

BTW - you can name any .png or .mp4 to the exact name of the "Emulator" to be used as a default when the artwork isn't present for a game (i.e. MAME.png, Sega Geneis.png, etc.). It's defined here under the Artwork Selection Order https://github.com/mickelson/attract/blob/v2.3.0/Readme.md

the_gamer

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Picture not found attract FREEZES
« Reply #2 on: May 11, 2018, 10:54:10 PM »
Theme: attrac-man.
Also: linux so any .exe is not really useful.
I will try it with another theme when i reinstall actual git version for now I am using the older version and need it to work.

progets

  • Hero Member
  • *****
  • Posts: 604
    • View Profile
Re: Picture not found attract FREEZES
« Reply #3 on: May 11, 2018, 10:57:03 PM »
You didn't mention the OS either so it's not like I had much to go on. ;-)

What do you see on the console when it freezes?

Are you using software or hardware video decoding? AM hardware decoding is newer in linux (not in 2.1.0).

Have your tried different video modes? Full Screen vs. Fill Screen vs. Etc.

I should also ask what Linux distro and are you using RetroPie scripts for your build?
« Last Edit: May 11, 2018, 11:06:13 PM by progets »

the_gamer

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Picture not found attract FREEZES
« Reply #4 on: May 12, 2018, 05:33:37 AM »
What do you see on the console when it freezes?

[source]
Invalid value for sf::BlendMode::Factor! Fallback to sf::BlendMode::Zero.
[/source]
This message even appears many times(a few dozen/hundred? Did not count.
[source]
*** Initializing display: 'daphne'
 - Loaded master romlist 'daphne' in 0 ms (7 entries kept, 0 discarded)
 - Constructed 2 filters in 0 ms (14 comparisons)
 - Loaded layout: /usr/share/attract/layouts/Basic/ (layout.nut)

*** Initializing display: 'mame'
 - Loaded master romlist 'mame' in 295 ms (11523 entries kept, 0 discarded)
 - Constructed 10 filters in 13 ms (115230 comparisons)
 - Loaded layout: /usr/share/attract/layouts/Attrac-Man/ (layout.nut)

*** Initializing display: 'DOS'
 - Loaded master romlist 'DOS' in 41 ms (48 entries kept, 0 discarded)
 - Constructed 2 filters in 0 ms (96 comparisons)
Uniform "bgl_RenderedTexture" not found in shader
 - Loaded layout: /home/cab/.attract/layouts/robospin-msdos.rar (robospin-msdos/layout.nut)

*** Initializing display: 'mame'
 - Loaded master romlist 'mame' in 78 ms (11523 entries kept, 0 discarded)
 - Constructed 10 filters in 12 ms (115230 comparisons)
 - Loaded layout: /usr/share/attract/layouts/Attrac-Man/ (layout.nut)
[/source]
Does not really look useful to me as the last message says the layout was loaded succesfully…
Are you using software or hardware video decoding? AM hardware decoding is newer in linux (not in 2.1.0).
Where to select this? I have no video aside from the standard intro video and all pictures are still images.

Have your tried different video modes? Full Screen vs. Fill Screen vs. Etc.
For attrac-man theme? Yes, does not seem to change anything.

I should also ask what Linux distro and are you using RetroPie scripts for your build?
Archlinux, building attract mode from aur: https://aur.archlinux.org/packages/attract-git/

the_gamer

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Picture not found attract FREEZES
« Reply #5 on: May 14, 2018, 07:28:56 AM »
It is getting worse. Today I updated my PC, recompiled newest attract-mode from git and it crashes with memory access error right after the intro video(memory access error is everything the error gives me, nothing more).

keilmillerjr

  • Hero Member
  • *****
  • Posts: 511
    • View Profile
Re: Picture not found attract FREEZES
« Reply #6 on: May 14, 2018, 01:15:35 PM »
Try uninstalling video drivers and reinstall latest driver.?

the_gamer

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Picture not found attract FREEZES
« Reply #7 on: May 18, 2018, 09:56:17 AM »
Somebody here: https://aur.archlinux.org/packages/attract says this has something to do with a change in ffmpeg. Does anybody know more about it?

nerdnils

  • Jr. Member
  • **
  • Posts: 15
    • View Profile
Re: Picture not found attract FREEZES
« Reply #8 on: May 23, 2018, 10:13:01 PM »
Nobody knows anything about this?

Enverex

  • Jr. Member
  • **
  • Posts: 24
    • View Profile
    • xNode - Internet Toolkit
Re: Picture not found attract FREEZES
« Reply #9 on: May 24, 2018, 01:25:50 PM »
There are now basically 2 critical issues with AttractMode. One can be worked around, the other not:

First is that it doesn't compile against FFMPEG 4 (see https://github.com/mickelson/attract/issues/442). This can be worked around at least.

The second issue is the one reported in this thread, wherein AttractMode just freezes (without any errors in the log/stderr) when it tries to load artwork that doesn't exist (see https://github.com/mickelson/attract/issues/440).

Unless the other guys commenting in this thread are familiar with FFMPEG or LIBSFML, we'll have to wait for Mickelson to reappear and have time to work on it.

the_gamer

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Picture not found attract FREEZES
« Reply #10 on: May 25, 2018, 08:44:23 AM »
There are now basically 2 critical issues with AttractMode. One can be worked around, the other not:

First is that it doesn't compile against FFMPEG 4 (see https://github.com/mickelson/attract/issues/442). This can be worked around at least.

The second issue is the one reported in this thread, wherein AttractMode just freezes (without any errors in the log/stderr) when it tries to load artwork that doesn't exist (see https://github.com/mickelson/attract/issues/440).

Unless the other guys commenting in this thread are familiar with FFMPEG or LIBSFML, we'll have to wait for Mickelson to reappear and have time to work on it.

Wow, second one was fast ^^ First one not, though but now I can compile it, but after the intro video attract-mode stays on a black screen and freezes or exits/closes. I don't know if the picture it is trying to load exists because I can not see which one it is trying to load… So the problem still persists for me. Ticket says it worked for you. So I am alone now, damn -.-
« Last Edit: May 25, 2018, 09:11:07 AM by the_gamer »

the_gamer

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Picture not found attract FREEZES
« Reply #11 on: May 26, 2018, 10:00:10 PM »
I don't understand why but a reboot solved this with the newest version… on linux o.O