Author Topic: Favourites not working properly ?  (Read 45479 times)

jimmer

  • Full Member
  • ***
  • Posts: 31
    • View Profile
Favourites not working properly ?
« on: July 09, 2014, 05:17:30 AM »

I have a single rom list (mame.txt)

I have several AM lists using it with different filters. See attached config. The reason for this approach is that I have swappable control panels, so the idea is that the user first chooses an appropriate list based on the control panel installed.

Anyway, I was hoping that pressing F would simply add or remove the highlighted game from mame.tag from any of the lists, but something goes wrong.

Everything works fine when I add favourites from my ALL list.   But it goes wrong when I add them from the 4way or 8way list. I think it applies the filter to the existing list.  ie if I try to add a favourite from the 4way list it removes all existing favourites that don't match the current (4way) filter, so I lose all the 8way games.

If it's meant to work like that, any ideas how I should arrange my menu system? I suppose I could make copies of my list with different names, but having separate favourite lists won't work quite so well (because eg more than 1 panel has 2way support)




Quote
list   4way+2way
   layout               attracman_4way
   romlist              mame
   filter               4way2way
      rule                 Control contains (4-way)|(2-way)
   filter               4way2way_Favourites
      rule                 Control contains (4-way)|(2-way)
      rule                 Favourite equals 1

list   Streetfighter
   layout               attracman_SF2
   romlist              mame
   filter               8way+dual
      rule                 Control contains (8-way)|(double)
   filter               8way_Favourites
      rule                 Control contains (8-way)|(double)
      rule                 Favourite equals 1

list   ALL_FAV
   layout               attracman
   romlist              mame
   filter               All
   filter               Favourites
      rule                 Favourite equals 1
[\QUOTE]


jimmer

  • Full Member
  • ***
  • Posts: 31
    • View Profile
Re: Favourites not working properly ?
« Reply #1 on: July 09, 2014, 05:34:16 AM »
The above applies to tags as well.

raygun

  • Administrator
  • Sr. Member
  • *****
  • Posts: 355
    • View Profile
Re: Favourites not working properly ?
« Reply #2 on: July 09, 2014, 05:52:04 AM »
Hi Jimmer,

That's a bug that will be fixed in the next release for both favs and tags.

see: https://github.com/mickelson/attract/issues/72

jimmer

  • Full Member
  • ***
  • Posts: 31
    • View Profile
Re: Favourites not working properly ?
« Reply #3 on: July 09, 2014, 06:05:10 AM »
Ah great.
And I see it is marked as fixed.

How long will I have to wait  for next release?

If sign into github, will I find beta releases?
or if I download the latest code and compile it myself, is it likely to work?

thanks,
and thanks for AttractMode

raygun

  • Administrator
  • Sr. Member
  • *****
  • Posts: 355
    • View Profile
Re: Favourites not working properly ?
« Reply #4 on: July 09, 2014, 06:43:04 AM »
The next release is almost ready, I just need some time to package everything up.  So  it'll be posted sometime in the next few days, maybe even tonight.

If you compile the most recent code from github yourself that will fix it too!

jimmer

  • Full Member
  • ***
  • Posts: 31
    • View Profile
Re: Favourites not working properly ?
« Reply #5 on: July 11, 2014, 03:26:04 AM »
I'll wait for the release then  :)
I'm sure things will go wrong if I try to compile on windows.