Author Topic: Demul In AM  (Read 421 times)

7ank0v1c

  • Full Member
  • ***
  • Posts: 31
  • For the LORD is good and his love endures forever
    • View Profile
Demul In AM
« on: June 24, 2018, 11:28:46 AM »
Hey guys, I am trying to get Demul to work properly on my computer, but am having a few problems with it.
I am using the following rom path setting in the config, which works perfectly with gdi images, but I also have cdi images and they obviously don't work with this setting.


-run=dc -image="[rompath]\[name].gdi"

Equally, I realize that this way means I can only have one rom in the folder, and other files would have to be replaced like 'track.bin' files


I tried this setting, but it doesn't seem to run any of the roms.

-run=dc -image=[romfilename]

Could someone help please, thanks in advance =D
« Last Edit: June 24, 2018, 02:18:16 PM by 7ank0v1c »
For the LORD is good and his love endures forever; his faithfulness continues through all generations. - Psalm 100:5

jedione

  • Hero Member
  • *****
  • Posts: 504
  • punktoe
    • View Profile
Re: Demul In AM
« Reply #1 on: June 24, 2018, 05:24:03 PM »
args                 -run=dc -image=[romfilename]

works for me...?
« Last Edit: June 24, 2018, 05:25:37 PM by jedione »
help a friend....

7ank0v1c

  • Full Member
  • ***
  • Posts: 31
  • For the LORD is good and his love endures forever
    • View Profile
Re: Demul In AM
« Reply #2 on: June 24, 2018, 06:14:37 PM »
hhhhhhhmmmmmmmmm???

Im going to guess that it will be some other settings?

Any ideas?

could you screenshot your settings that work?
For the LORD is good and his love endures forever; his faithfulness continues through all generations. - Psalm 100:5

progets

  • Hero Member
  • *****
  • Posts: 633
    • View Profile
Re: Demul In AM
« Reply #3 on: June 24, 2018, 10:09:06 PM »
The post above is correct. The "other setting" would be specific to your install.

A search would find your answer. http://forum.attractmode.org/index.php?topic=503.msg7514#msg7514
« Last Edit: June 24, 2018, 10:12:36 PM by progets »

7ank0v1c

  • Full Member
  • ***
  • Posts: 31
  • For the LORD is good and his love endures forever
    • View Profile
Re: Demul In AM
« Reply #4 on: June 25, 2018, 05:28:12 AM »
I figured it out now. Thanks for the help guys. I selected the wrong GD-ROM plugin. Make sure gdrimage is selected  :)
For the LORD is good and his love endures forever; his faithfulness continues through all generations. - Psalm 100:5

7ank0v1c

  • Full Member
  • ***
  • Posts: 31
  • For the LORD is good and his love endures forever
    • View Profile
Re: Demul In AM
« Reply #5 on: June 25, 2018, 05:41:12 AM »
I have another problem now, sometimes when I load a game it doesn’t load it in full screen mode and have to exit it and go back in. It’s like the luck of the draw with wether or not it’s going to work. Any ideas?
For the LORD is good and his love endures forever; his faithfulness continues through all generations. - Psalm 100:5

jedione

  • Hero Member
  • *****
  • Posts: 504
  • punktoe
    • View Profile
Re: Demul In AM
« Reply #6 on: June 25, 2018, 07:15:14 AM »
open demule,

config > video,   checkbox "fullscreen"  then ok.

 ;)
help a friend....

7ank0v1c

  • Full Member
  • ***
  • Posts: 31
  • For the LORD is good and his love endures forever
    • View Profile
Re: Demul In AM
« Reply #7 on: June 25, 2018, 08:31:28 AM »
Already did that haha, I thought that was obvious. The issue is it does it sometimes but sometimes it doesn’t. Maybe 1 in every 4 attempts it does it. Then I just exit and try again and it usually works but was wondering if there was a fix for us fellow OCD people that need it all to work straight away, haha.
For the LORD is good and his love endures forever; his faithfulness continues through all generations. - Psalm 100:5

7ank0v1c

  • Full Member
  • ***
  • Posts: 31
  • For the LORD is good and his love endures forever
    • View Profile
Re: Demul In AM
« Reply #8 on: June 26, 2018, 02:29:21 PM »
ANYONE?
For the LORD is good and his love endures forever; his faithfulness continues through all generations. - Psalm 100:5

progets

  • Hero Member
  • *****
  • Posts: 633
    • View Profile
Re: Demul In AM
« Reply #9 on: June 26, 2018, 02:47:07 PM »
You can try adjusting the Window Mode and see if that helps.

Configure-->General-->Window Mode = Fill Screen|Fullscreen|Window|Window (no border)

Also check to see what resolution AM is using vs. Demul.

brendan1495

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Demul In AM
« Reply #10 on: August 16, 2018, 02:14:29 PM »
ANYONE?

Been messing with this for ages myself. This works for me

-run=dc -image="[romfilename]"


rand0m

  • Full Member
  • ***
  • Posts: 27
    • View Profile
Re: Demul In AM
« Reply #11 on: August 20, 2018, 03:16:54 AM »
ANYONE?

Demul runs Dreamcast and a bunch of Arcade systems based on DC like Atimiswave, Naomi, Hikaru etc. Hikaru & Gaelco games won't run in full screen unless you press Alt+Enter manually (Demul Limitation atm). DC games should be running without a hitch, any specific title which shows this behavior?

You might wanna check Reicast OIT core (Retroarch) .