Author Topic: command line param issue (was: issue with mouse / spinner not being recognised)  (Read 58 times)

agent4125

  • Newbie
  • *
  • Posts: 2
    • View Profile
Hi

I've installed GroovyArcade, running groovymame through AttractMode.

If I launch groovymame directly from a terminal in the LXDE desktop,  when I hit TAB and try to configure dial/paddle inputs for certain games to use the spinner I have attached, it works fine - moving the spinner and groovymame recognises it as "Mouse1Y".

If I then launch AttractMode from the same LXDE desktop session, and run groovymame from there (the command line parameters it sends is just "[name]", the game I am trying to configure is outrun) then the spinner is not recognised - it doesn't show anything when I move it when trying to assign paddle controls etc.

Is AttractMode doing something to disable the mouse/spinner or am I missing something?  It only seems to not be able to recognise the mouse devices (I actually have 2 spinners attached) when running through AttractMode.

Also to note:  Both spinners are attached to the same HID device, spinner 1 uses the Y axis, spinner 2 uses the X axis.  They are GroovyGameGear's TurboTwist2 spinners, connected via a single USB connection.  I've had no problem running this same hardware setup before through AttractMode on Windows 7.

Ah, I've just remembered another issue.  I was trying to get groovymame to run with some debug output to a file, but changing the command line parameters within AttractMode to "-v [name] >[name].txt" then causes groovymame to fail to run the rom correctly, I just get pushed back to AttractMode instantly.

Thanks
« Last Edit: July 10, 2018, 12:21:21 PM by agent4125 »

agent4125

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: issue with mouse / spinner not being recognised
« Reply #1 on: July 10, 2018, 12:20:34 PM »
OK, it seems attractmode cannot run groovymame in the same way as running on a bash command prompt.

I need to run it with -v (verbose) output, and redirect the output to a file, so I can see debug information to solve a configuration issue with groovymame.

However, attractmode just seems to pass all parameters to groovymame, which is not expecting the ">[name].txt" as a parameter...

In attractmode, I have set the command line parameters for groovymame to be:  -v [name] > [name].txt

Here's the attract mode log showing this: -

Code: [Select]

[arcade@GroovyArcade ~]$ attract
Starting Attract-Mode v2.2.1-43 (Linux)
Config: /home/arcade/.attract/attract.cfg

*** Initializing display: 'MAME'
 - Loaded master romlist 'MAME' in 1 ms (105 entries kept, 0 discarded)
 - Constructed 1 filters in 0 ms (105 comparisons)
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
attempt to connect to server failed
 ! NOTE: Use the 'Fill Screen' window mode if you want multiple monitor support to function correctly
 - Loaded layout: /home/arcade/.attract/layouts/attracman/ (layout.nut)
*** Running: groovymame -v outrunb > outrunb.txt
Error: unknown option: >
 ! NOTE: Use the 'Fill Screen' window mode if you want multiple monitor support to function correctly
 ! NOTE: Use the 'Fill Screen' window mode if you want multiple monitor support to function correctly
 - Loaded layout: /home/arcade/.attract/layouts/attracman/ (layout.nut)
[arcade@GroovyArcade ~]$

As you can see: -

*** Running: groovymame -v outrunb > outrunb.txt
Error: unknown option: >

Not sure if this is a bug or something that cannot be fixed, or if someone knows of another way I can get mame to output debug info to a file when run from attractmode (the configuration issue I need to resolve only happens when running groovymame directly from attractmode).

Thanks
« Last Edit: July 10, 2018, 12:22:19 PM by agent4125 »