Author Topic: Important message to all using window mode “Window (No Border)” on Windows  (Read 311 times)

Oomek

  • Sr. Member
  • ****
  • Posts: 214
    • View Profile
Check your window.am file if it’s not containing the negative offset

Code: [Select]
position -1,-1
size 1922,1082

If it looks like this you may be crippling the performance by skipping Windows’ borderless optimizations.
You can manually set it to the correct size

Code: [Select]
position 0,0
size 1920,1080

Or change your window mode to Full Screen and then back to Window (No Border)
The true window mode “Borderless Window” will be implemented in the future that won’t require this workaround.

This happens if you set Window (No Border) after Fill Screen.

progets

  • Hero Member
  • *****
  • Posts: 721
    • View Profile
Great catch! It might explain some unusual problems that have been randomly seen on the forum.

I have pretty static builds so I would have never seen this. Your eye for detail is exquisite.

Thanks for bringing excellence to Attract-Mode.

progets

  • Hero Member
  • *****
  • Posts: 721
    • View Profile
P.S. I think you deserve a promotion to "Hero Member" or above. Your contributions in the past year have been instrumental to the progression of AM.

Oomek

  • Sr. Member
  • ****
  • Posts: 214
    • View Profile
Nahh... I don’t brag for titles, but thanks for appreciation.

Here are another 2 issues I found that may affect the borderless performance:

If you have DPI scale set in display settings to anything other than 100% do the following:
Right click on the shortcut to attract or on the attract.exe and tick disable DPI scaling on the compatibility tab, or
set the DPI override to "Aplication" (the options may vary depending on the version of Windows)

If your desktop resolution does not match the native resolution of the display it can also hinder the performance of the borderless mode. You can fix it by setting "GPU Scaling" in your driver settings.

By doing this you adding an extra framebuffer so when AM reads the snap from the disk it has 32ms instead of 16ms
to update the images. That makes the animations much smoother.

Or just use Full Screen if you can and you do not have issues with it like screen flashing on launching games :)
« Last Edit: July 12, 2018, 05:43:58 AM by Oomek »