Author Topic: Version 2.4.1 bug fix release  (Read 238 times)

raygun

  • Administrator
  • Sr. Member
  • *****
  • Posts: 366
    • View Profile
Version 2.4.1 bug fix release
« on: August 17, 2018, 10:06:21 PM »
We're pleased to announce the newest release of Attract-Mode: version 2.4.1.  This version fixes a few of the bugs found in the recently released 2.4 and adds some 'official' Arch Linux, Debian and Ubuntu packages to the available downloads.

Enjoy!


# Changelog #

## Commits from v2.4.0 to v2.4.1

### Andrew Mickelson (21 commits)

* Bump to version 2.4.1
* Added log message when frontend unexpectedly loses focus
* Added code to handle mame/mess media types during first run autoconfiguration
* Misc. code cleanup (removed unused variables, etc)
* Issue #282 - fixed mapped keys from working when frontend doesn't have focus
* Switch behaviour of "Fillscreen mode" to a true borderless window (#467)
* Added bound check (+ correction) for video pts
* Improved frame skipping for videos
* Fix 'non-blocking mode wait' when game has multiple loading screens
* Fix sound handling when interrupted by game launch
* Updated setting of hwaccel in FFmpeg.  Added videotoolbox for Mac OS X
* Issue #459 - fixed listbox selection background fading/colour setting

### progets (1 commits)

* RocketLauncher plugin (#470) - Written by ArcadeBliss

### Radek Dutkiewicz (1 commits)

* Added manifest to windows build (#461)

keilmillerjr

  • Hero Member
  • *****
  • Posts: 514
    • View Profile
Re: Version 2.4.1 bug fix release
« Reply #1 on: August 18, 2018, 01:31:32 AM »
Quick release timing! Thank you!

Manual do Fliperama

  • Jr. Member
  • **
  • Posts: 10
    • View Profile
Re: Version 2.4.1 bug fix release
« Reply #2 on: August 18, 2018, 03:03:30 AM »
The group Attract Mode Brasil thanks.

https://www.facebook.com/groups/334886130197658/

iOtero

  • Sr. Member
  • ****
  • Posts: 146
    • View Profile
Re: Version 2.4.1 bug fix release
« Reply #3 on: August 18, 2018, 06:39:56 AM »

* Issue #459 - fixed listbox selection background fading/colour setting


This layout with 2.4.1 version:

Code: [Select]
fe.load_module("animate");

local flx = fe.layout.width;
local fly = fe.layout.height;
local flw = fe.layout.width;
local flh = fe.layout.height;

my_time <- 600;
my_delay <- 3500;

// Listbox
::OBJECTS <- {lbx = fe.add_listbox(flx*0.76, fly*0.33, flw*0.20, flh*0.64)}
OBJECTS.lbx.rows = 21;
OBJECTS.lbx.charsize = 24;
OBJECTS.lbx.align = Align.Left;
OBJECTS.lbx.bg_alpha = 0;
OBJECTS.lbx.set_rgb(255,255,255);
OBJECTS.lbx.selbg_alpha = 0;
OBJECTS.lbx.set_sel_rgb(255,0,0);
OBJECTS.lbx.sel_alpha = 255;

local move_lbx3 = {when = Transition.ToNewSelection, property = "alpha", start = 0, end = 255, time = 1} 
local move_lbx4 = {when = When.ToNewSelection, property = "alpha", start = 255, end = 0, time = my_time, delay = my_delay} 
animation.add(PropertyAnimation(OBJECTS.lbx, move_lbx3));
animation.add(PropertyAnimation(OBJECTS.lbx, move_lbx4));

Has this result:


https://www.youtube.com/watch?v=Z4vmmwdcFps



I do not see that the bug has been fixed.