Author Topic: Update Linux version to make thegamedb.net scrape images?  (Read 110 times)

wdcook3

  • Newbie
  • *
  • Posts: 7
    • View Profile
Update Linux version to make thegamedb.net scrape images?
« on: August 02, 2018, 08:25:07 PM »
Recently I have been trying to add some new systems to my machine and have been getting the 302 error when trying to scrape for new images of thegamesdb.  After some reading in a couple threads, even ones outside of here it seems that the url and api has changed.  I read in another post that a user linked them to the nightly windows builds.  I'm a pretty advanced windows user but a very basic Lubuntu Linux user and am not sure if I have to compile a new version to get it working and if so, if there is any easy way to go about that.   Much appreciated for the help in advance!

wdcook3

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Update Linux version to make thegamedb.net scrape images?
« Reply #1 on: August 03, 2018, 02:44:49 AM »
Also, I am using the DaveG version found here http://forum.attractmode.org/index.php?topic=817.0 from what I read mickelson as linked to here has an update for the fix https://github.com/mickelson/attract/commit/fbef389de8725fd3228f3960cd9af63b31edae67 Now the question if that solves my problem does anyone know the best way to go about switching from the Daveg version to the mickelson without breaking everything?  Thanks in advanced again!

progets

  • Hero Member
  • *****
  • Posts: 610
    • View Profile
Re: Update Linux version to make thegamedb.net scrape images?
« Reply #2 on: August 03, 2018, 10:27:25 PM »
That PPA hasn't been updated in almost two years.

My advice is to backup (make copies of) your Attract-Mode directories and then compile Attract-Mode from current source code. I have never used a PPA for Attract-Mode so I don't know if it uses the same standard paths that a freshly compiled version would but if it doesn't you can always copy any files you need from your backup directories.

You can see the steps to compile on the wiki but it should be something like this...
Code: [Select]
sudo apt-get update && sudo apt-get -y install git libsfml-dev libopenal-dev libavformat-dev libfontconfig1-dev libfreetype6-dev libswscale-dev libavresample-dev libarchive-dev libjpeg-dev libglu1-mesa-dev
git clone http://github.com/mickelson/attract attract
cd attract
make
sudo make install
cd ..
rm -rf attract

If things go wrong you can post details on the forum for help or resort to your backup directories to restore the Attract-Mode setup you already have today.

Compiling yourself is a much better option and not as hard as you might think, especially on Linux. Once you have done it once you will have a setup that can easily be update later without relying on anyone's outdated PPA.

wdcook3

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Update Linux version to make thegamedb.net scrape images?
« Reply #3 on: August 04, 2018, 03:07:36 AM »
Highly appreciate the input!  I will give that ago on another hard drive tomorrow.  When I first started messing around with my first version of Attract mode running the Daveg PPA I tried to do the compile and replace all the other files with the ones the compile made but that didn't go so well.  So this time I will start from scratch on the compile and move over my .attract folder set back up the emulators and I'll give it a go.

Thanks again!