Author Topic: Retropie won't boot into Attract mode...  (Read 130 times)

fumblingwisdom

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Retropie won't boot into Attract mode...
« on: December 02, 2018, 11:06:56 AM »
When I start my retropie, I'm taken to the terminal and need to type "attract' to launch attract mode...

Where do I go and what do I have to do so that it will boot into attract mode on it's own ? or even emulation station, I'm not picky. I would just like to be able to use it without having a keyboard around...

Thanks alot !

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 673
    • View Profile

fumblingwisdom

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: Retropie won't boot into Attract mode...
« Reply #2 on: December 02, 2018, 12:14:35 PM »
I'm a total newb and would hate to mess up this build permanently ...

So I would do this from the terminal with commands ? Does anyone no specially what I would write ?

Isn't there a word document I would edit instead ? Thanks again

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 673
    • View Profile
Re: Retropie won't boot into Attract mode...
« Reply #3 on: December 02, 2018, 02:43:02 PM »
From the terminal:
Code: [Select]
$ sudo nano /etc/rc.local
Note the commands to exit and such at the bottom of the terminal window. control + q will ask if you want to save the buffer to file.

You need to comment out with a hash, remove or modify the part where you I assume would see a bit about emulation station. I assume it would be in this file, but there is technically more than one way of starting an application on boot. If you don’t see it, also check /home/pi/.bashrc.

You could probably just add the word attract. Double ampersands are used to execute more than one thing, so take note of that. If it does not work, you might have to use an absolute path. But I don’t see why it shouldn’t. Sorry I can not give you a 100% answer because I do not have your setup.

Reboot your pi:
Code: [Select]
$ sudo reboot

Favdeacon

  • Full Member
  • ***
  • Posts: 95
    • View Profile
Re: Retropie won't boot into Attract mode...
« Reply #4 on: December 02, 2018, 10:25:18 PM »
From the terminal:
Code: [Select]
$ sudo nano /etc/rc.local
Note the commands to exit and such at the bottom of the terminal window. control + q will ask if you want to save the buffer to file.
Isn't that control+x? It is at least on my Retropie 4.4 (based on Debian Stretch). Control + x just says "XON ignored, mumble mumble".

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 673
    • View Profile
Re: Retropie won't boot into Attract mode...
« Reply #5 on: December 03, 2018, 01:29:00 AM »
From the terminal:
Code: [Select]
$ sudo nano /etc/rc.local
Note the commands to exit and such at the bottom of the terminal window. control + q will ask if you want to save the buffer to file.
Isn't that control+x? It is at least on my Retropie 4.4 (based on Debian Stretch). Control + x just says "XON ignored, mumble mumble".

Probably. It says what options are. I just wasn’t sure if he knew what the character represented by ^ meant.

kent79

  • Hero Member
  • *****
  • Posts: 523
    • View Profile
Re: Retropie won't boot into Attract mode...
« Reply #6 on: December 03, 2018, 01:37:32 AM »