Author Topic: [PC] Re-installing but keeping all settings and emulator setup  (Read 96 times)

deanobirko

  • Newbie
  • *
  • Posts: 3
    • View Profile
[PC] Re-installing but keeping all settings and emulator setup
« on: December 06, 2018, 01:28:10 AM »
Hi there, new to the forum.  Ive spent about 6 hours a week for about 2 months setting up a massive Attract Mode with all emulators, roms and artwork/videos on my Windows Mame machine.

My kid inadvertently turned off the power without shutting down and now I get a runtime error when first running attract mode, causing the program to close.

Is there any way of reinstalling attract mode but keeping all my themes, rom lists, artwork etc so it starts working again.  Im about ready to give up =(

Thanks for your help.

rand0m

  • Full Member
  • ***
  • Posts: 73
    • View Profile
Re: [PC] Re-installing but keeping all settings and emulator setup
« Reply #1 on: December 06, 2018, 06:48:28 AM »
Most time consuming thing is properly maintained romlists, which are in plain text. Everything else can be easily replaced so don't worry too much. BTW I can fully appreciate your feelings after having setup a complete emulation machine :D

Whats the runtime error you are getting?

toothlessgrinn

  • Sr. Member
  • ****
  • Posts: 101
    • View Profile
Re: [PC] Re-installing but keeping all settings and emulator setup
« Reply #2 on: December 06, 2018, 07:37:28 AM »
try replacing just the attract.exe

this happened to me too once and i just replaced the exe and it fixed it.
hope this helps. very sorry if it dont.
we came , we saw , we lost LOTS of quarters...

Win 7
Asus mobo amd 64bit 3core
12g ram
4 player. Custom built woody cab
46" plasma screen with 22" marquee

deanobirko

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: [PC] Re-installing but keeping all settings and emulator setup
« Reply #3 on: December 06, 2018, 12:37:10 PM »
Thanks  guys. Tried swapping exe to no avail.

The error is:

The application has requested the runtime to terminate in an unusual way.

The line before that:

Line = (1) column =(9): error expression expected

toothlessgrinn

  • Sr. Member
  • ****
  • Posts: 101
    • View Profile
Re: [PC] Re-installing but keeping all settings and emulator setup
« Reply #4 on: December 06, 2018, 02:03:22 PM »
sorry man i got the exact same error once and replaced the exe and it fixed my problem.
i also went from 64 bit to 32bit v2.3 and now my stuff works flawlessly
hope you get it fixed!

we came , we saw , we lost LOTS of quarters...

Win 7
Asus mobo amd 64bit 3core
12g ram
4 player. Custom built woody cab
46" plasma screen with 22" marquee

progets

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 749
    • View Profile
Re: [PC] Re-installing but keeping all settings and emulator setup
« Reply #5 on: December 06, 2018, 09:09:28 PM »
Download and install a fresh AttractMode in a different folder from your current install and see if it runs or if you get the same error. If it runs then there's something wrong with your existing AttractMode build. If it doesn't run then your problem is probably with Microsoft Visual C++ Redistributable, DirectX or video drivers.

rand0m

  • Full Member
  • ***
  • Posts: 73
    • View Profile
Re: [PC] Re-installing but keeping all settings and emulator setup
« Reply #6 on: December 07, 2018, 01:27:50 AM »
^ As progets suggested.