Author Topic: emulator setting for pc_games (portable)  (Read 436 times)

Giacomo1982

  • Full Member
  • ***
  • Posts: 74
    • View Profile
emulator setting for pc_games (portable)
« on: December 23, 2018, 05:16:32 AM »
I'm not able to set Emulator in AM to run .bat files (pc games)

I found this setting in the forum but when I launch the game nothing happens

where I'm wrong?


# Generated by Attract-Mode v2.5.1
#
executable           cmd
args                 /c "[romfilename]"
rompath              ..\..\roms\pc_portable
romext               .bat
system               PC
artwork    boxart          ..\..\artworks\pc_portable\boxart
artwork    cartart         ..\..\artworks\pc_portable\cartart
artwork    flyer           ..\..\artworks\pc_portable\flyer
artwork    snap            ..\..\artworks\pc_portable\snap
artwork    wheel           ..\..\artworks\pc_portable\wheel

rand0m

  • Sr. Member
  • ****
  • Posts: 208
    • View Profile
Re: emulator setting for pc_games (portable)
« Reply #1 on: December 23, 2018, 10:07:40 AM »
"cmd /c" works at my end. Have you tried it with absolute path in rompath?

On second thought you are calling a bat file from a bat file, so try the following:

1.
executable           cmd
args                 /c start "" "[romfilename]"

2.
executable           cmd
args                 /c call "[romfilename]"
« Last Edit: December 23, 2018, 10:26:40 AM by rand0m »

Giacomo1982

  • Full Member
  • ***
  • Posts: 74
    • View Profile
Re: emulator setting for pc_games (portable)
« Reply #2 on: December 23, 2018, 11:14:07 AM »
Thanks rand0m your solutions brought me into the right way!

Emulator settings:

executable           cmd
args                 /c start "" "[romfilename]"
rompath              ..\..\roms\pc_portable\
romext               .bat
system               PC




.bat

cd %~dp0
mrboom\Mrboom.exe
exit
« Last Edit: December 23, 2018, 10:33:45 PM by Giacomo1982 »