Author Topic: New user here and many questions.  (Read 1347 times)

Autotec

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
New user here and many questions.
« on: January 06, 2019, 05:33:00 PM »
Hello everybody. I'm new this this so please be easy on me. I've been searching and reading for 2 days without any resolution. This is my first Arcade build, and I'm running into some issues with Attract Mode. I'll start with MAME runs fine, all of the controls work and the games play well. The correct names come up in the simple GUI and I can select them.

I installed Attract Mode and all I get is a Pac Man video with games on the left side. The names aren't correct though. Plus I can't select any of them.

There is one difference in the instructions I've been reading and what I'm seeing in the AM configuration menu, and that would be the "Working Directory". What should that be pointed at? My thought is that is why I'm having issues. Attached is the image from the main screen and my configuration screen.

Like I said, I've searched and I'm sorry if these questions have been asked before. But I couldn't find any answers. Any help would be appreciated.

Thank you, Justin


progets

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 875
    • View Profile
Re: New user here and many questions.
« Reply #1 on: January 06, 2019, 05:52:42 PM »
1. why is you MAME exe called "mae64.exe"? Looks like a typo.
2. add your rompath to the mame.ini (in MAME emulator folder)
Code: [Select]
rompath                   roms;D:\MAME\roms

Autotec

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: New user here and many questions.
« Reply #2 on: January 06, 2019, 06:07:10 PM »
Sorry, I attached the wrong picture. I noticed that after I took the first image. All of the wording is correct now. Good eye, you made me double check.

progets

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 875
    • View Profile
Re: New user here and many questions.
« Reply #3 on: January 06, 2019, 06:34:15 PM »
What about your mame.ini file that I mention in #2?

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 930
    • View Profile
Re: New user here and many questions.
« Reply #4 on: January 06, 2019, 07:27:23 PM »
I assume mae64 isn’t the official mame binary. Sometimes people share their modified „arcade only“ binaries, and I have seen instance where generating xml does not work on them. Can you manually generate a proper xml from the binary? If not, use an official binary to generate an xml. I think mame is now hosting the file pre-generated too.

Autotec

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: New user here and many questions.
« Reply #5 on: January 07, 2019, 05:05:20 AM »
No, it actually is “mame.exe”. It was a typo on my own part that I didn’t notice until after I took the picture. That has been fixed, but nothing has changed. And that I find kinda strange.

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 930
    • View Profile
Re: New user here and many questions.
« Reply #6 on: January 07, 2019, 05:20:04 AM »
No, it actually is “mame.exe”. It was a typo on my own part that I didn’t notice until after I took the picture. That has been fixed, but nothing has changed. And that I find kinda strange.

Did you try what I asked? Can you generate the xml manually?

Autotec

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: New user here and many questions.
« Reply #7 on: January 07, 2019, 05:43:46 AM »
No, it actually is “mame.exe”. It was a typo on my own part that I didn’t notice until after I took the picture. That has been fixed, but nothing has changed. And that I find kinda strange.

Did you try what I asked? Can you generate the xml manually?

I’m going to sound dumb, but how would I attempt to do that? This is the part of this build where I’m out of my comfort zone.

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 930
    • View Profile
Re: New user here and many questions.
« Reply #8 on: January 07, 2019, 05:54:19 AM »
No, it actually is “mame.exe”. It was a typo on my own part that I didn’t notice until after I took the picture. That has been fixed, but nothing has changed. And that I find kinda strange.

Did you try what I asked? Can you generate the xml manually?

I’m going to sound dumb, but how would I attempt to do that? This is the part of this build where I’m out of my comfort zone.


For you, open cmd and type the following:

D:/MAME/MAME v.204/mame.exe mame -listxml >D:/MAME/MAME v.204/mame.xml

Let me know if it’s generated. It should be a large file measured in mb.

https://docs.mamedev.org/commandline/commandline-all.html

zpaolo11x

  • Sr. Member
  • ****
  • Posts: 483
    • View Profile
    • My deviantart page
Re: New user here and many questions.
« Reply #9 on: January 07, 2019, 05:58:52 AM »
Very basic doubt here: have you generated the romlist from attract mode UI?

Autotec

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: New user here and many questions.
« Reply #10 on: January 07, 2019, 06:46:14 AM »
Thank you, I will try as soon as I get home from work. Like I said, this is my weakest point in this build, but I’m learning a ton.

As for the rom list, it shows it created it during the setup process.

Thanks again guys.

Bgoulette

  • Sr. Member
  • ****
  • Posts: 112
  • I wrote a book.
    • View Profile
    • BlakeGoulette.com
Re: New user here and many questions.
« Reply #11 on: January 07, 2019, 06:54:52 AM »
Hey Autotec,

It looks like what happened with my latest AM install: the romlist generator (I'm not at my PC right now: forgive misleading terms!) included all the devices and drivers in its mame.txt file: that's what it looks like you're seeing based on your screen shot. (Should be under attract/emulators/mame.txt, or something close to that.) I have a relatively small subset of games (no full romsets), so it wasn't too bad for me to go in and manually delete the offending lines. You can always comment out anything suspicious with a pound sign if you're not sure what it is.

zpaolo11x

  • Sr. Member
  • ****
  • Posts: 483
    • View Profile
    • My deviantart page
Re: New user here and many questions.
« Reply #12 on: January 07, 2019, 07:16:01 AM »
It looks like what happened with my latest AM install: the romlist generator (I'm not at my PC right now: forgive misleading terms!) included all the devices and drivers in its mame.txt file: that's what it looks like you're seeing based on your screen shot.

Good point! I remember when I set up my MAME + AM system I put all the actual game roms in one folder and all the devices, bioses etc in another folder. Then MAME settings point to both folders, while AM ROM folder setting only points to the "actual games" ROM folder. In this way you should clean up the romlist from drivers etc

Autotec

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: New user here and many questions.
« Reply #13 on: January 07, 2019, 07:47:02 AM »
Gives me something else to look at. I don’t set the pc up, one of my friends did that for me. How can I tell the difference between a game rom and the other info?

zpaolo11x

  • Sr. Member
  • ****
  • Posts: 483
    • View Profile
    • My deviantart page
Re: New user here and many questions.
« Reply #14 on: January 07, 2019, 08:14:08 AM »
I'm not sure I can post such links here but if you google for mame roms bios devices you should find a page from internet archive that has a list of them for MAME 0.185. Don't know for newer versions