Author Topic: Not working on crt (when booting Attract mode the video flies around)  (Read 627 times)

Neil

  • Full Member
  • ***
  • Posts: 46
    • View Profile
Hello,

I might have made the mistake of configuring Attract Mode when the PC was still hooked up to an lcd, and now that I'm on a CRT I seem to be unable to open attract mame. What can I do to fix this?

Thank you.

progets

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 856
    • View Profile
Re: Not working on crt (when booting Attract mode the video flies around)
« Reply #1 on: January 20, 2019, 06:06:37 PM »
With AttractMode not running, rename \attractmode\window.am or edit it to contain the proper resolution.

Neil

  • Full Member
  • ***
  • Posts: 46
    • View Profile
Re: Not working on crt (when booting Attract mode the video flies around)
« Reply #2 on: January 20, 2019, 07:29:50 PM »
Thank you so much! Do I also input the frequency somewhere? It seems like it's going at 31khz because I can connect to the lcd and it will work till I quit attract mode after which it goes back to 15khz and becomes incompatible.

Also out of curiosity, had I launched Attract Mode for the first time from the crt would it have set up and adjusted to 15khz right away or was this an avoidable step in setting it up for running on a crt?

progets

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 856
    • View Profile
Re: Not working on crt (when booting Attract mode the video flies around)
« Reply #3 on: January 20, 2019, 08:25:14 PM »
I'm not aware of any frequency settings in AttractMode. It should use whatever frequency the operating system is using.

Neil

  • Full Member
  • ***
  • Posts: 46
    • View Profile
Re: Not working on crt (when booting Attract mode the video flies around)
« Reply #4 on: January 20, 2019, 09:29:36 PM »
Thanks, so then the problem is that I previously launched it in a higher resolution (I had 800x600 at the time I believe). I got home and tried looking for the "window.am" but can't find it. I do have a attract.am though. I don't seem to have an attractmode sub folder to look into either. I'm running v2.5.1 windows7 64bits.

progets

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 856
    • View Profile
Re: Not working on crt (when booting Attract mode the video flies around)
« Reply #5 on: January 20, 2019, 10:04:58 PM »
I just remembered that the window.am file only gets created and used when running in certain AttractMode window modes. To try to get your CRT working you might want to try each window mode and see if one works for you.

Configure-->General-->Windows Mode = Fullscreen Mode, Fill Screen (default), Window (no boards), Window

Neil

  • Full Member
  • ***
  • Posts: 46
    • View Profile
Re: Not working on crt (when booting Attract mode the video flies around)
« Reply #6 on: January 20, 2019, 10:14:16 PM »
Thank you, I will try that first thing tomorrow as I'm about to go to bed. I really appreciate your help. Also now I've learned how to work in the .cfg files and I see there is a window_mode option in the cfg so I should be able to change those modes outside of Attract Mode which will come in handy in case Attract Mode refuses to launch on the 640x480 crt like it was earlier.

progets

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 856
    • View Profile
Re: Not working on crt (when booting Attract mode the video flies around)
« Reply #7 on: January 20, 2019, 11:55:26 PM »
Please confirm if your issue is with the resolution inside of AttractMode or inside of the MAME emulator.

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 863
    • View Profile
Re: Not working on crt (when booting Attract mode the video flies around)
« Reply #8 on: January 20, 2019, 11:57:32 PM »
Remove window.am. It will get auto generated.
Edit attract.cfg and remove window mode parameter. It will set to default.
Attract will use default resolution. This is 640x480 interlaced on windows 7+. raspberryPi will be whatever you set in /boot/config.txt. PS the lcd I have will accept a 15khz signal and digitally process it.
« Last Edit: January 20, 2019, 11:59:15 PM by keilmillerjr »

Neil

  • Full Member
  • ***
  • Posts: 46
    • View Profile
Re: Not working on crt (when booting Attract mode the video flies around)
« Reply #9 on: January 21, 2019, 11:01:50 AM »
Thank you for the replies. I still don't have a window.am, even after having changed to window mode to various settings and having restarted, so I'm unable to delete it.

So for now I will edit out the window mode parameter from the attract.cfg as per keilmillerjr's recommendations and will try again this afternoon when I get back to the crt, I'll report back the results after doing so.

It's probably not the emulator that's at fault here because the issue I have begins the moment I open attract Mode itself while on the crt. I don't see anything other than a black fuzzy image with horizontal lines moving at fast speed up or down. At this point I need to disconnect the vga from the crt to go back to the lcd to get a proper image and then all works fine, of course the moment I quit attract mode I end up on a black screen on the lcd and have to go back to the crt to see windows properly in 640x480i 15khz.

 I think this might have something to do with the fact that I configured Attract Mode on the lcd before moving to the crt. So am I correct in assuming that thre is no frequency setting so technically the image is still being sent in 15khz but the lcd digitally processes it to work despite the 31khz requirement there?

EDIT: By the way do different themes have different compatible resolutions? I'm using Game Station and wondering whether or not it is compatible with 640x480.
« Last Edit: January 21, 2019, 11:47:51 AM by Neil »

Neil

  • Full Member
  • ***
  • Posts: 46
    • View Profile
Re: Not working on crt (when booting Attract mode the video flies around)
« Reply #10 on: January 21, 2019, 03:54:05 PM »
So I found the window.am which must have apeared at some point. I deleted it and erased the window parameter from the attract.cfg but sadly Attract Mode still opens up with horizontal lines flying around haywire forcing me to restart the PC or to unplug the VGA to connect it to an LCD. GroovyMame launches games just fine through the command prompt so I don't think it's a problem with Mame either. Not sure what to do next.

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 863
    • View Profile
Re: Not working on crt (when booting Attract mode the video flies around)
« Reply #11 on: January 21, 2019, 05:49:54 PM »
Those horizontal moving lines sounds to me like an incompatible frequency. I am not no expert in crt, just a user of them. You have attract set to run in different res compatibility mode? Try windowed mode as well. Attract uses desktop res, so this is odd to me that it would try changing resolutions. If all else fails, try installing a fresh copy of attract in a different location and see if it works.

Neil

  • Full Member
  • ***
  • Posts: 46
    • View Profile
Re: Not working on crt (when booting Attract mode the video flies around)
« Reply #12 on: January 21, 2019, 10:17:33 PM »
Yes that's what I suspect too. Thanks for that.

I will wait to complete the atom-15 flashing which currently I'm stuck at not knowing how to extract a bios of my card, but once I figure it out I will persist with Attract Mode since it's my preferred frontend. Most likely a full delete and reinstall is necessary. Are there no hidden configs that get generated and saved outside of the main Attract Mode folder that might still have saved info or settings from the previous install?

Neil

  • Full Member
  • ***
  • Posts: 46
    • View Profile
Re: Not working on crt (when booting Attract mode the video flies around)
« Reply #13 on: January 21, 2019, 11:35:15 PM »
Alright so I succeeded with Atom-15 and am now fully on the crt. I deleted the entire folder of Attract Mode. Unzipped the original zip and named it differently and still it won't start at all. I get those horizontal diagonal lines flying around. Having reinstalled it should start with the most basic settings no?

One point worth mentioning is that I am still with testsigning mode on. The reason for this was in the past when I turned it off it seemed to revert away from emudrivers (basically forcing me to connect to an lcd) so I just decided to live with it.

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 863
    • View Profile
Re: Not working on crt (when booting Attract mode the video flies around)
« Reply #14 on: January 22, 2019, 01:17:07 AM »
Do not turn test signing off. As far as I know, windows install of attract is all contained in the same folder. Anyone confirm?