Author Topic: segmentation fault after update  (Read 225 times)

therui

  • Newbie
  • *
  • Posts: 9
    • View Profile
segmentation fault after update
« on: June 21, 2019, 06:20:48 AM »
hi guys
after updating atrract mode via retropie
i get this message
/opt/retropie/configs/all/autostart.sh: line 2: 534 segmentation fault
i tried atrract in the command line
but it gives me segmentation fault message
heres my autostart.sh
attract #auto

my ES-Start.sh
emulationstation #auto

and my AM-Start.sh
# Original
# emulationstation #auto
# stty -echo;attract &> /dev/null; stty echo
# attract > /dev/null 2>&1
attract

i did no modify a thing just updated and got the error
hope someone can help me out
thank you guys



progets

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 893
    • View Profile
Re: segmentation fault after update
« Reply #1 on: June 21, 2019, 03:27:58 PM »
Your update was unsuccessful. If you can't run "attract" from the command line then Attract-Mode is broke and it has nothing to do with your autostart.sh file. Your autostart.sh just can't run "attract" because it's broke.

Read the Pi FAQ http://forum.attractmode.org/index.php?topic=1249.msg9046#msg9046 step 1 and its warning. If you upgrade differently than you originally installed you might have an issue, otherwise perform the update again to fix your broken AM (and take note of any errors or issues). If you still have issues please provide details about your pre-update setup (i.e. how you originally installed AM, versions, ffmpeg installed or not, firmware, etc).

therui

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: segmentation fault after update
« Reply #2 on: June 22, 2019, 02:50:05 AM »
thanks progets
i will give it another shot

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 980
    • View Profile
Re: segmentation fault after update
« Reply #3 on: June 22, 2019, 04:02:14 AM »
I am confused. Your seg-fault is on a file which is not the ones you posted. Are you sure you pinpointed it correctly? Try actually launching attract from the terminal and not through scripts.

therui

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: segmentation fault after update
« Reply #4 on: June 22, 2019, 12:02:37 PM »
Hi
Simply like typing attract in the terminal?
I am not sure I know how to do that