Author Topic: Compilation of Attract-Mode in Raspberry pi 4  (Read 2932 times)

iOtero

  • Sr. Member
  • ****
  • Posts: 414
    • View Profile
Compilation of Attract-Mode in Raspberry pi 4
« on: August 06, 2019, 06:51:05 AM »
I bought a Raspberry pi 4 4GB and i installed Raspbian Buster Lite.

I tried to compile Attract-Mode following the instructions Keilmillerjr has on GitHub (https://github.com/keilmillerjr/Raspberry-Pi-MAME-Setup-Guide) and that had worked perfectly for me on Raspbian Stretch Lite and Raspberry pi 3B +.

FFmpeg, SFML and Attract-Mode has compiled easily and without problems.

But to launch AM, it does nothing and gives this error message:

* failed to add service - already in use?

Could someone tell me why?

Note for Keil: In the instructions for SFML, there is a missing line:

sudo make install
Nacer a los 15 años Una novela de iOtero

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1165
    • View Profile
Re: Compilation of Attract-Mode in Raspberry pi 4
« Reply #1 on: August 06, 2019, 09:05:19 AM »
Whats your memory split/over clock settings?

Have you compiled a newer mame? Im curious for a speed test comparison between pi 3b+ and 4.

iOtero

  • Sr. Member
  • ****
  • Posts: 414
    • View Profile
Re: Compilation of Attract-Mode in Raspberry pi 4
« Reply #2 on: August 06, 2019, 09:50:14 AM »
Whats your memory split/over clock settings?

Have you compiled a newer mame? Im curious for a speed test comparison between pi 3b+ and 4.

Overclock, nothing...
gpu mem = 512


If I can't compile Attract-Mode, why would i want to compile the MAME?   :-[

The emulators interest me only if I can make them work through Attract-Mode.  ::)

The truth is that i have tried to compile SDL 2.0.10 and I have not succeeded.  :'(

If nobody helps me, i will try to compile SDL 2.0.8 again. 8)

A few minutes ago i have compiled RetroArch, but it only works with graphic environment. If raspbian is started in console mode, retroarch does not work. And i do not know why. I guess by opengles... But i haven't tried any games yet.

I've tried Lakka and Dreamcast games work great on my pi 4. D2, Aqua GT, Shenmue...   In pi 3B +, they moved like lame turtles...  :P

« Last Edit: August 12, 2019, 07:26:25 AM by iOtero »
Nacer a los 15 años Una novela de iOtero


iOtero

  • Sr. Member
  • ****
  • Posts: 414
    • View Profile
Re: Compilation of Attract-Mode in Raspberry pi 4
« Reply #4 on: August 06, 2019, 01:55:13 PM »
That is a really high value. Try something lower?

https://www.raspberrypi.org/documentation/configuration/config-txt/memory.md

Yes, it is a very high value, with 256MB is more than enough. And by the way I already got the AM compilation in pi 4.
« Last Edit: August 13, 2019, 11:30:06 AM by iOtero »
Nacer a los 15 años Una novela de iOtero

alinke2000

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Compilation of Attract-Mode in Raspberry pi 4
« Reply #5 on: April 27, 2020, 10:10:51 PM »
getting the same problem, can you share what you did to fix? thanks!

tonberryhunter

  • Full Member
  • ***
  • Posts: 57
    • View Profile
Re: Compilation of Attract-Mode in Raspberry pi 4
« Reply #6 on: May 22, 2020, 07:55:25 PM »
Any updates on getting Attract Mode working on the Pi4?

sickle

  • Full Member
  • ***
  • Posts: 63
    • View Profile
Re: Compilation of Attract-Mode in Raspberry pi 4
« Reply #7 on: May 22, 2020, 09:25:48 PM »
Any updates on getting Attract Mode working on the Pi4?

not sure if this works on the pi 4, but i did it on a pi 2 with retropie 4.6: you can just install retropie, go to "manage optional packages" and install attract mode. then select it from the retropie menu, and from now on, the pi will boot into attract mode

tonberryhunter

  • Full Member
  • ***
  • Posts: 57
    • View Profile
Re: Compilation of Attract-Mode in Raspberry pi 4
« Reply #8 on: May 24, 2020, 03:31:04 PM »
Quote
not sure if this works on the pi 4, but i did it on a pi 2 with retropie 4.6: you can just install retropie, go to "manage optional packages" and install attract mode. then select it from the retropie menu, and from now on, the pi will boot into attract mode

Thanks sickle and I do have a few Attract Mode Retropie builds for my older Raspberry Pis I was just hoping for a way to get Attract Mode running on the Pi4.  I waited a year or so to jump on the Pi4 bandwagon and Its sad to see that development for it is actually behind the older slower Pi systems.  Like many things are still broken or missing from the Buster image for Pi4. 

tonberryhunter

  • Full Member
  • ***
  • Posts: 57
    • View Profile
Re: Compilation of Attract-Mode in Raspberry pi 4
« Reply #9 on: June 01, 2020, 12:58:03 AM »
So I sort of got Attract Mode working on Pi 4 but both situations arent ideal yet.

1. One way is to run via xinit or x11 : https://github.com/mickelson/attract/wiki/Compiling-on-the-Raspberry-Pi-4-(Raspbian-Buster)

Make sure to install the Pixel Desktop from the RetroPie Setup menu beforehand. 

Update Buster
Code: [Select]
sudo apt-get update; sudo apt-get upgrade
sudo reboot

Create a build environment
Code: [Select]
cd ~; mkdir develop

Install dependencies
Code: [Select]
sudo apt-get install cmake libflac-dev libogg-dev libvorbis-dev libavutil-dev libavcodec-dev libavformat-dev libavfilter-dev libswscale-dev libavresample-dev libopenal-dev libfreetype6-dev libudev-dev libjpeg-dev libudev-dev libfontconfig1-dev libglu1-mesa-dev libsfml-dev libxinerama-dev libcurl4-openssl-dev

Download and build Attract-Mode
Code: [Select]
cd ~/develop
git clone --depth 1 https://github.com/mickelson/attract attract
cd attract
make USE_XINERAMA=1 USE_LIBCURL=1
sudo make install USE_XINERAMA=1 USE_LIBCURL=1

Delete build files
Code: [Select]
cd ~; rm -r -f ./develop

2.  The other is via kms/drm which is closer to how Attract Mode is run on the Pi 3 : https://github.com/mickelson/sfml-pi/issues/13