Author Topic: Vintage DOS theme [Release v1.2]  (Read 2287 times)

Yaron2019

  • Full Member
  • ***
  • Posts: 68
    • View Profile
Vintage DOS theme [Release v1.2]
« on: August 26, 2019, 11:59:31 PM »
Cool theme for MS-DOS.

Thanks for asahendrix for the art, iOtero and jedione for the fading list code!


YouTube:
https://www.youtube.com/watch?v=syC5j5BqZDo

Download:
https://mega.nz/#!EIVzjAYC!V63TlujbdzbjMIru52UHcatvNjuU6CvbElci53Jhi7w


Update v1.2:
- User can now choose delay and fade-in/out times for game list and snap videos (Huge thanks to iOtero for the code and support!)

Update v1.1:
- Added option to show boxart
- Added option to play a long version of the PC ambient sound
« Last Edit: December 05, 2019, 10:09:03 AM by Yaron2019 »

iOtero

  • Sr. Member
  • ****
  • Posts: 390
    • View Profile
Re: Vintage DOS theme [Release]
« Reply #1 on: August 27, 2019, 04:20:00 AM »
Finally something new!

I was already tired of seeing copy of copy of copy...  including mine...

Thanks for the theme. I like very much.
I love that on my laptop the eyes shine to the Alien every time i access the ssd... :D

iOtero

  • Sr. Member
  • ****
  • Posts: 390
    • View Profile
Re: Vintage DOS theme [Release]
« Reply #2 on: August 27, 2019, 05:27:03 AM »
I just tried it and on my Desktop PC 16:9 it works very well, but it doesn't suit my Raspberry pi-based system with a 4:3 monitor.

Do you plan to make a version for 4:3 resolutions: (640x480, 800x600, 1024x768, etc.)?
I love that on my laptop the eyes shine to the Alien every time i access the ssd... :D

Yaron2019

  • Full Member
  • ***
  • Posts: 68
    • View Profile
Re: Vintage DOS theme [Release]
« Reply #3 on: August 27, 2019, 07:14:07 AM »
Finally something new!

I was already tired of seeing copy of copy of copy...  including mine...

Thanks for the theme. I like very much.

I just tried it and on my Desktop PC 16:9 it works very well, but it doesn't suit my Raspberry pi-based system with a 4:3 monitor.

Do you plan to make a version for 4:3 resolutions: (640x480, 800x600, 1024x768, etc.)?

Thank you iOtero.

Judging by your work on ioamiga, you will be way better than me doing a 4:3 and 16:9 version. By all means please do it!
Also feel free to change whatever you want - just make sure to release it to us as well!  :)
« Last Edit: August 27, 2019, 11:44:56 AM by Yaron2019 »

iOtero

  • Sr. Member
  • ****
  • Posts: 390
    • View Profile
Re: Vintage DOS theme [Release]
« Reply #4 on: August 28, 2019, 05:53:52 AM »
Finally something new!

I was already tired of seeing copy of copy of copy...  including mine...

Thanks for the theme. I like very much.

I just tried it and on my Desktop PC 16:9 it works very well, but it doesn't suit my Raspberry pi-based system with a 4:3 monitor.

Do you plan to make a version for 4:3 resolutions: (640x480, 800x600, 1024x768, etc.)?

Thank you iOtero.

Judging by your work on ioamiga, you will be way better than me doing a 4:3 and 16:9 version. By all means please do it!
Also feel free to change whatever you want - just make sure to release it to us as well!  :)

I wish i had time... Well, if one day i copied your idea, I'll let you know... Thank you.  :)

And... Of course, it won't carry wheels ...  ;D ;D ;D
« Last Edit: August 28, 2019, 05:55:55 AM by iOtero »
I love that on my laptop the eyes shine to the Alien every time i access the ssd... :D

myriadgamers

  • Full Member
  • ***
  • Posts: 40
    • View Profile
Re: Vintage DOS theme [Release v1.1]
« Reply #5 on: August 30, 2019, 08:03:21 AM »
This is a nice setup and if and when I add dos box to my rig I think I will definitely use this. Is there an option to change the Delay for when the videos start while selecting games?
Arcade Machine 1:
AMD 8350 black 4ghz 8 Cores
20 gigs of DDR 3 Ram
500 gb SSD
4 tb Storage drive

Yaron2019

  • Full Member
  • ***
  • Posts: 68
    • View Profile
Re: Vintage DOS theme [Release v1.1]
« Reply #6 on: August 30, 2019, 10:53:59 AM »
This is a nice setup and if and when I add dos box to my rig I think I will definitely use this. Is there an option to change the Delay for when the videos start while selecting games?

Thanks. As for the game snap delay, I have tried to add a timer but was unsuccessful. Unfortunately, at this stage I don't understand Squirrel script well enough... If anyone can add this feature it will be great.

iOtero

  • Sr. Member
  • ****
  • Posts: 390
    • View Profile
Re: Vintage DOS theme [Release v1.1]
« Reply #7 on: August 31, 2019, 07:13:16 AM »
This is a nice setup and if and when I add dos box to my rig I think I will definitely use this. Is there an option to change the Delay for when the videos start while selecting games?

Thanks. As for the game snap delay, I have tried to add a timer but was unsuccessful. Unfortunately, at this stage I don't understand Squirrel script well enough... If anyone can add this feature it will be great.

Use this code:

Code: [Select]
class UserConfig
{
</ label = "Delay Time",
help = "The time (in milliseconds) it takes to start hiding the frames, list and wheels. Set to 0 for no hide.",
options = "0,1000,1500,2000,2500,3000,3500,4000,4500,5000,5500,6000",
order = 5
/> set_ms_delay = "3500";

</ label = "Hide Time",
help = "The time (in milliseconds) that it takes for the wheels, list and frames to hide.",
options = "100,200,300,400,500,600,700,800,900,1000,1100,1200",
order = 6
/> set_ms_hide = "600";
}

local my_config = fe.get_config();

my_time <- 0;
try {my_time = my_config["set_ms_hide"].tointeger();} catch(e) {}
my_delay <- 0;
try {my_delay = my_config["set_ms_delay"].tointeger();} catch(e) {}

local artwk = fe.add_listbox(flx*0.385, fly*0.17, flw*0.31, flh*0.32);
artwk.preserve_aspect_ratio = true;
artwk.trigger = Transition.EndNavigation;

local move_artwk1 = {when = Transition.ToNewSelection, property = "alpha", start = 0, end = 255, time = 1} 
local move_artwk2 = {when = When.ToNewSelection, property = "alpha", start = 255, end = 0, time = my_time, delay = my_delay} 
animation.add(PropertyAnimation(artwk, move_artwk1));
animation.add(PropertyAnimation(artwk, move_artwk2));
« Last Edit: September 01, 2019, 04:26:58 AM by iOtero »
I love that on my laptop the eyes shine to the Alien every time i access the ssd... :D

Yaron2019

  • Full Member
  • ***
  • Posts: 68
    • View Profile
Re: Vintage DOS theme [Release v1.1]
« Reply #8 on: August 31, 2019, 08:12:00 AM »
iOtero, I added it to the code and it's not working as intended. Attached is the layout.nut -- what did I do wrong?
Thanks!

rand0m

  • Sr. Member
  • ****
  • Posts: 260
    • View Profile
Re: Vintage DOS theme [Release v1.1]
« Reply #9 on: September 01, 2019, 01:06:33 AM »
iOtero, I added it to the code and it's not working as intended. Attached is the layout.nut -- what did I do wrong?
Thanks!

I am using the following code for displaying video on top of snap after a brief delay, but following code should do what you want (delay settings can be changed to fit the need). Got this code from liquid8d's post, so all thnks to him :)

Code: [Select]

//Video Starts Playing After 1 Second In Place of Snap
local settings = {
   delay_timer = 0,
   play_delay = 1000,
   stop_play = 235000
}

local video = fe.add_artwork("video", 680,705,472,355)
video.preserve_aspect_ratio = true;
video.trigger = Transition.EndNavigation;

function vid_on_transition(ttype, var, transition_time) {
    if ( ttype == Transition.StartLayout || ttype == Transition.ToNewList || ttype == Transition.FromOldSelection ) {
        video.visible = false
        settings.delay_timer = fe.layout.time
    }
    return false
}

function vid_on_tick(tick_time) {
  if ( video.video_playing && tick_time - settings.delay_timer >= settings.play_delay ) video.visible = true
}

fe.add_ticks_callback(this, "vid_on_tick")
fe.add_transition_callback(this, "vid_on_transition")
« Last Edit: September 01, 2019, 01:21:31 AM by rand0m »

iOtero

  • Sr. Member
  • ****
  • Posts: 390
    • View Profile
Re: Vintage DOS theme [Release v1.1]
« Reply #10 on: September 01, 2019, 04:28:55 AM »
Sorry, i hid the video instead of the listbox. Blame the damn "copy paste"...

Here you have the correct code.
« Last Edit: September 01, 2019, 04:30:47 AM by iOtero »
I love that on my laptop the eyes shine to the Alien every time i access the ssd... :D

takoni

  • Full Member
  • ***
  • Posts: 38
    • View Profile
Re: Vintage DOS theme [Release v1.1]
« Reply #11 on: September 02, 2019, 02:47:30 AM »
very nice layout Man!!!! thanks

Yaron2019

  • Full Member
  • ***
  • Posts: 68
    • View Profile
Re: Vintage DOS theme [Release v1.1]
« Reply #12 on: September 06, 2019, 07:38:17 AM »
Sorry, i hid the video instead of the listbox. Blame the damn "copy paste"...

Here you have the correct code.

Sorry for not replying earlier, I was busy with unpleasant things.
I suspect you uploaded the wrong layout file - the code is the same as it was... can you please confirm?

iOtero

  • Sr. Member
  • ****
  • Posts: 390
    • View Profile
Re: Vintage DOS theme [Release v1.1]
« Reply #13 on: September 06, 2019, 11:12:21 AM »
You're right, I hope I don't make more mistakes...  :-[

All the data, including the listbox, could have been included in a single surface and we would have only had to fade the surface, but I like it better that way, in case you want to vary the fade and/or wait speed of each of the elements.
« Last Edit: September 06, 2019, 11:17:26 AM by iOtero »
I love that on my laptop the eyes shine to the Alien every time i access the ssd... :D

Yaron2019

  • Full Member
  • ***
  • Posts: 68
    • View Profile
Re: Vintage DOS theme [Release v1.1]
« Reply #14 on: September 06, 2019, 11:54:53 PM »
You're right, I hope I don't make more mistakes...  :-[

All the data, including the listbox, could have been included in a single surface and we would have only had to fade the surface, but I like it better that way, in case you want to vary the fade and/or wait speed of each of the elements.

Your code works and we're almost there. My initial intent was that the video is not viewed or heard when the layout starts and plays only when the user moves to a new selection.
The current code starts to play the video immediately. What I want to achieve is:
1. When layout starts snap video is hidden and silent.
2. When moved to new selection the snap video playing is delayed for X milliseconds.

So the user moves to a new selection, the list fades after X milliseconds and then the snap video starts!
I tried to do that with the latest code but I can get only two situations: either the video stays turned off or it begins to play and then restarts after x time. This is really frustrating.