Author Topic: No German Umlaut (ä,ü,ö,ß) in Overview  (Read 136 times)

Neosys

  • Full Member
  • ***
  • Posts: 40
    • View Profile
No German Umlaut (ä,ü,ö,ß) in Overview
« on: December 10, 2019, 06:28:22 AM »
Hi! I use the Overview game descriptions in my theme. As far as it works.

But no umlauts are displayed. In German there is "ö, ä, ü & ß". Instead of umlautes a square is displayed.

In English, there are no umlauts.

Is there a way to change this? It works on History.dat, but I do not want to use it.

Thank you.

jedione

  • Hero Member
  • *****
  • Posts: 854
  • punktoe
    • View Profile
Re: No German Umlaut (ä,ü,ö,ß) in Overview
« Reply #1 on: December 10, 2019, 08:14:25 AM »
may have something to do with the way it is saved,,  unicode vs ANSI

i do know keyboard ↑ ↓ alt characters in a theme,  dont work and show up as a square..

help a friend....

iOtero

  • Sr. Member
  • ****
  • Posts: 412
    • View Profile
Re: No German Umlaut (ä,ü,ö,ß) in Overview
« Reply #2 on: December 10, 2019, 08:54:14 AM »
In Spanish we also have special characters that the English language does not use: á Á é É í Í or Ó ú Ú ñ Ñ ¿ ¡
Before Attract-Mode had difficulties to put them on the screen, but after a bug report that i passed to the staff, between Mickelson and Oomek they solved it. Now i have no problem, but i have to use UTF-8 encoding, not ANSI, in the romlists and overviews.

It is also important that the font that uses Attract-Mode and its layouts include those special characters.

On this page all sources are free and there is a language section where you can filter the language in which you want the sources: https://www.fontsquirrel.com
I love that on my laptop the eyes shine to the Alien every time i access the ssd... :D

Neosys

  • Full Member
  • ***
  • Posts: 40
    • View Profile
Re: No German Umlaut (ä,ü,ö,ß) in Overview
« Reply #3 on: December 10, 2019, 09:37:26 AM »
Thanks!

I encoded my Overview txt file with UTF-8-without BOM (byte-order mark), because before the first letter was a miss.

What also works is to save the text file as .nut and then rename it back to .txt.

Now I have to change all my overviews first again.  ;)

iOtero

  • Sr. Member
  • ****
  • Posts: 412
    • View Profile
Re: No German Umlaut (ä,ü,ö,ß) in Overview
« Reply #4 on: December 10, 2019, 09:51:19 AM »
Thanks!

I encoded my Overview txt file with UTF-8-without BOM (byte-order mark), because before the first letter was a miss.

What also works is to save the text file as .nut and then rename it back to .txt.

Now I have to change all my overviews first again.  ;)

Find a program called UTFCast Express, automate those changes.  ;)
I love that on my laptop the eyes shine to the Alien every time i access the ssd... :D

Neosys

  • Full Member
  • ***
  • Posts: 40
    • View Profile
Re: No German Umlaut (ä,ü,ö,ß) in Overview
« Reply #5 on: December 10, 2019, 12:28:50 PM »
Thanks for the hint. A program I do not necessarily need, because I need the overviews mainly for my systems eventull the one or the other layout. but thanks anyway my friend.