Author Topic: [SOLVED] Scraper Issues?  (Read 306 times)

myk.robinson

  • Newbie
  • *
  • Posts: 7
    • View Profile
[SOLVED] Scraper Issues?
« on: February 28, 2020, 06:52:21 AM »
Wondering if others are having issues with the scraper not grabbing everything for Mame? I did a test of Attract Mode on a PC at the office, then I took a Dell micro PC and installed Manjaro Linux with mame and attract mode with the intention of hooking it into my TV at home. I found that the scraper did not pull all of the video, wheels, etc. My test at the office pulled everything, but this was a few weeks ago. Is there a known issue with the scraper (gamesdb) or is there a way to add alternative/better scrapers?

And, is there a setting in  Attract Mode to have it rescan the games list and re-scrape at launch versus doing it manually? I have several thousand ROMS and have not added them all, as I am going through them to decide which ones i REALLY want, so it would be nice to have it check each time I relaunch.

Thanks for helping a rookie figure this out.
« Last Edit: March 16, 2020, 08:59:36 AM by myk.robinson »

hermine.potter

  • Hero Member
  • *****
  • Posts: 508
    • View Profile
Re: Scraper Issues?
« Reply #1 on: February 28, 2020, 07:28:34 PM »
@ myk.robinson
-do you use on your office PC Manjaro Linux too?
-same AM version?

//EDIT:
your question about scrape:
tested it at the moment.
i have added a new romfile to my mame emulator and used the "Generate Romlist" and "Scrape Artwork" again.
AM added the new game to list.
only the new artworks for the new game was added.
all existing artworks remained untouched.

« Last Edit: February 28, 2020, 09:29:17 PM by hermine.potter »
AM Version : 2.6.1
Input : Mad Catz Brawlstick; Mouse; Keyboard; Xbox360 Wireless
Cabinet : Yes
OS : Windows10 Pro
System : Dell Precision T3500 ; Intel X5650 ; 12GB RAM
Emulators : zsnes; mame; dosbox; scummvm; bsnes; fusion; openbor; windows_games; winuae; video; flashgames; vice; visualb

myk.robinson

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Scraper Issues?
« Reply #2 on: February 29, 2020, 03:41:35 AM »
@hermine.potter

Thanks for the response. Yes, it's the same Manjaro Linux on the office PC.

I read a post on the thegamersdb website that suggests they recently had a issue and something about requesting API keys for your apps to work. I assume attractmode already has an API key loaded for the app to talk to thegamersdb but perhaps there is just still some oddities going on with their servers. The games I have loaded are not obscure titles, and my process is the same as yours, which is to generate a new list then scrape for new artwork.

Is there a log I can read after an attempted scrape that might give me some clues? Maybe I can share the list attractmode generated, wonder if there may be done mismatches and the scraper isn't sure what to retrieve. Just some ideas, but if there is a lot, that'd be helpful

myk.robinson

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Scraper Issues?
« Reply #3 on: March 01, 2020, 03:44:02 PM »
Here's a video showing my experience. Really hoping there is a log or something I can find that might tell me what's up, but so far, searching the scraper folder seems to only show some text files that show the games I have, publishers, etc.

Surely i am not the only one having this issue? Getting the scraper to work properly is the only thing standing between me and the most awesome TV on the block ;)

https://photos.app.goo.gl/83dU7VvwUycadDQAA

Thanks

myk.robinson

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Scraper Issues?
« Reply #4 on: March 01, 2020, 03:52:45 PM »
Wondering if this has anything at all to do with the issue:

https://forums.thegamesdb.net/viewtopic.php?f=5&t=1652

This announcement was made on Feb 4th, and the latest build of attract mode is January 17th. Perhaps something needs to be changed in the API calls?

myk.robinson

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Scraper Issues?
« Reply #5 on: March 02, 2020, 05:41:36 AM »
UPDATE: I saw the sticky up top regarding adding artwork. For the time being, I'll just go through and manually add videos, etc, using the resources listed. Still quite curious to figure out the scraper if I can, though..

myk.robinson

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Scraper Issues?
« Reply #6 on: March 16, 2020, 08:59:07 AM »
UPDATE: I was setting up Attract Mode for a friend and noticed scraping worked on his build (same manajaro/mame combination as i use). I compared to see what the difference was, and his only listed listxml. I changed mine to the same, and lo and behold, scraping started working as advertised. I guess changing to thegamesdb is what "broke" mine.... sometimes its best to just leave things alone.