Author Topic: pie 4 AM install  (Read 213 times)

jedione

  • Hero Member
  • *****
  • Posts: 957
  • punktoe
    • View Profile
pie 4 AM install
« on: November 13, 2020, 06:59:16 AM »
hey guys,  a few days ago  Mahuti posted his compile instrutions,

and they worked just fine..ie no errors,   but after i go into ES and their is no option to restart
in AM,  then whent to console, and put in "attract"  like ya would in lynx but no go
using winSCP  i can see were it all was sucsesfully compiled,

anyone know how to get it to possibley run...thanks 

quote:
This is my compile instructions on Raspbian Buster on Pi 4. I have totally different instructions for the 3b+. Started with a CLEAN RetroPie install... i tried on a few other installs and didn't have much luck, so I started clean and it worked then. After adding other stuff in, it still seems fine.

Code: [Select]
*update*

sudo apt-get update; sudo apt-get upgrade

*make development folder*

cd ~; mkdir develop
        cd ~/develop

*Install "sfml-pi" dependencies*

sudo apt-get install -y cmake libflac-dev libogg-dev libvorbis-dev libopenal-dev libjpeg8-dev libfreetype6-dev libudev-dev libdrm-dev libgbm-dev libegl1-mesa-dev
   
*Download and build sfml-pi*

git clone --depth 1 https://github.com/mickelson/sfml-pi sfml-pi
mkdir sfml-pi/build; cd sfml-pi/build
cmake .. -DSFML_DRM=1 -DSFML_OPENGL_ES=1
        make -j4
sudo make install
sudo ldconfig

*Install attractmode dependencies

sudo apt-get install -y cmake libflac-dev libogg-dev libvorbis-dev libavutil-dev libavcodec-dev libavformat-dev libavfilter-dev libswscale-dev libavresample-dev libopenal-dev libfreetype6-dev libudev-dev libjpeg-dev libudev-dev libfontconfig1-dev libglu1-mesa-dev libxinerama-dev libcurl4-openssl-dev

*Download and build Attract-Mode*

git clone --depth 1 https://github.com/mickelson/attract attract
cd attract
make USE_DRM=1 USE_MMAL=1          # it didn't seem to work when I added this -> USE_GLES=1
sudo make install USE_DRM=1 USE_MMAL=1

*Check to see that it was installed correctly.*

attract -v
help a friend....

mahuti

  • Administrator
  • Sr. Member
  • *****
  • Posts: 128
    • View Profile
    • Github Repositories
Re: pie 4 AM install
« Reply #1 on: November 13, 2020, 09:37:13 PM »
Are you launching it remotely?

You can type

Code: [Select]
attract --loglevel debug
from a remote console to see any errors. If you can run attract -v then it should at least be installed and working.

For what its worth, on RetroPie you can now just install from the retropie setup. Seems to work just fine that way. The out of the box version has mmal support so compiling may not be necessary anymore.
« Last Edit: November 14, 2020, 07:44:51 AM by mahuti »

jedione

  • Hero Member
  • *****
  • Posts: 957
  • punktoe
    • View Profile
Re: pie 4 AM install
« Reply #2 on: November 14, 2020, 06:29:59 AM »
"on Retrofit, you can now just install from the retropie setup"


what is this i tried to search,,, retrofit   and don't find anything?
help a friend....

jedione

  • Hero Member
  • *****
  • Posts: 957
  • punktoe
    • View Profile
Re: pie 4 AM install
« Reply #3 on: November 14, 2020, 06:36:07 AM »
so i whent back and ran this bit of code again,,

git clone --depth 1 https://github.com/mickelson/attract attract
   cd attract
   make USE_DRM=1 USE_MMAL=1         USE_GLES=1
   sudo make install USE_DRM=1 USE_MMAL=1

attract v

and it is now working........thanks
help a friend....

mahuti

  • Administrator
  • Sr. Member
  • *****
  • Posts: 128
    • View Profile
    • Github Repositories
Re: pie 4 AM install
« Reply #4 on: November 14, 2020, 07:47:55 AM »
Quote
and it is now working........thanks

Awesome!!

Quote
    what is this i tried to search,,, retrofit

Im sorry. That was autocorrect at work. I had attempted to type RetroPie.

jedione

  • Hero Member
  • *****
  • Posts: 957
  • punktoe
    • View Profile
Re: pie 4 AM install
« Reply #5 on: November 14, 2020, 08:06:05 AM »
just one last little thing...do you happen to know how i might be able to boot right into AM

help a friend....

mahuti

  • Administrator
  • Sr. Member
  • *****
  • Posts: 128
    • View Profile
    • Github Repositories
Re: pie 4 AM install
« Reply #6 on: November 14, 2020, 11:32:18 AM »
Code: [Select]
sudo pico /opt/retropie/configs/all/autostart.sh

Change emulationstation to attract.


Also, you might find this guide handy. Any time I do anything on the Pi I document it. https://github.com/mahuti/arcadepi