Author Topic: New user with a couple basic questions  (Read 2847 times)

robbbby

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
New user with a couple basic questions
« on: January 31, 2016, 07:54:43 AM »
First off I wanted to say how much i'm liking attract mode, nicer looking then MaLa and nowhere near as impossible to setup as hyperspin.

I was going through the basic setup and came across this part

Quote
6. System identifier:
This is used in conjunction with the system/source scraper below when using the games.db selection. (For mame this is not needed.) You would enter your system name here. (ex. Sega Genesis)

7. Info source scraper:
This is used to grab information for your list. Press up or down to choose from mame, mess, or gamesdatabase.db. Mame is used for the mame emulator, mess is used for the mess emulator, gamesdatabse.db grabs info from the Internet.  (here we choose mame)

I'm trying to setup mame, but for Info source scraper mame is not an option?  I have list.xml, gamesdatabase, mess and a couple other things but no mame.  Is this the setting that is supposed read from my mame.xml to populate my game list?
Also, all my games still read in the short formed file name style.  AM is obviously pointing to the proper executable for mame since the games load and run fine, i'm guessing this has more to do with the above not properly reading from my mame.xml?

Thanks

Edit - nevermind, found another great post detailing how to import mame.xml files using the -i switch
« Last Edit: January 31, 2016, 09:16:20 AM by robbbby »

akafox

  • Hero Member
  • *****
  • Posts: 797
    • View Profile
Re: New user with a couple basic questions
« Reply #1 on: January 31, 2016, 10:24:43 AM »
I believe I wrote the above on how to set up AM...

I have never used the I switch...it is strange you are having this problem. The main reason that the scraper is not used with mame is because most of the artwork can be downloaded easily. Also "extra-info" files are maintained regularly.

Using "mame" as the info source should get you a list of "long names" use the list.xml however..you should have mame as an option you don't need a "list.xml" as AM will pull that from the mame.exe..(just like mala and hyperspin).

Strange though as you said the games launch fine..thus you have it set up right seems like...you should be getting your list from the mame.exe.

Also note that you can scrape mame videos using the scraper in the scraper settings..I have not tried it yet though.
People want life easy..then complain about it

robbbby

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: New user with a couple basic questions
« Reply #2 on: January 31, 2016, 01:07:03 PM »
akafox, that was in fact from your howto, which was a breeze to follow, thanks for writing it up.

I'm not sure if I went wrong somewhere but I checked over and over.  Currently for the mame emulator, I have the info source scraper left blank, the -i command took my mame.xml and created a mame.txt in (I believe) /romlist.

Regardless, it's working great using the source of info that I wanted.

akafox

  • Hero Member
  • *****
  • Posts: 797
    • View Profile
Re: New user with a couple basic questions
« Reply #3 on: January 31, 2016, 08:24:54 PM »
Regardless, it's working great using the source of info that I wanted.

guess that is all that matters ;)  well except that AM won't make me a sandwich....
People want life easy..then complain about it

robbbby

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: New user with a couple basic questions
« Reply #4 on: February 01, 2016, 04:03:31 AM »
My next step is to try and start adding other emulators to AM, hopefully it is as easy as it was to setup mame.

akafox

  • Hero Member
  • *****
  • Posts: 797
    • View Profile
Re: New user with a couple basic questions
« Reply #5 on: February 02, 2016, 11:06:51 AM »
It will be..the basic setup is the same for all emulators...

however remember each emulator has it's own arguments...
People want life easy..then complain about it

robbbby

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: New user with a couple basic questions
« Reply #6 on: February 02, 2016, 04:21:44 PM »
I've added a few and you're right, it's pretty straight forward, i'm loving how easy yet configurable everything is.

You bring up something i've been meaning to ask, and that's with regards to command line switches and arguments for loading each emulator.

Generally speaking, when would one even use any arguments?  Take mame for example, what would I use any arguments for, does it not just use the settings in mame.ini and use those when the program executes?
I thought must emulators store all video/audio/etc. data in a .cfg or .ini that it uses at runtime?

bionictoothpick

  • Sr. Member
  • ****
  • Posts: 247
  • He who laughs lasts.
    • View Profile
Re: New user with a couple basic questions
« Reply #7 on: February 02, 2016, 07:20:10 PM »
When you are using Retroarch you probably would pass additional information...

akafox

  • Hero Member
  • *****
  • Posts: 797
    • View Profile
Re: New user with a couple basic questions
« Reply #8 on: February 02, 2016, 10:39:20 PM »
If you want to play games with different settings...for example I can have a game come up rotated or use a different resolution as the rest of my games...

Example..I have ans old computer that i set up to use as a cocktail table. Some of these games is cocktail mode will start with the screen upside down from player one's perspective. Start the with the screen flipped with an argument and tat solves that problem neatly.

Mame is VERY configurable all the way down to the individual game itself. Mainly I just set up a vector.ini a neogeo.ini and make a custom ctrlr file. The vector.ini for vector games...they work differently than raster...and the neogeo.ini just so I can load the unibios.
People want life easy..then complain about it