Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Oomek

Pages: 1 2 [3] 4 5 ... 21
31
Themes / Re: Ambience HD theme v0.7 beta [Released]
« on: November 30, 2019, 12:04:14 PM »
OpenGL ES is a crippled version of OpenGL. It's for mobile and embedded systems. There is no reason to use it on a PC. I have no idea why it's showing up.

32
Themes / Re: Ambience HD theme v0.7 beta [Released]
« on: November 30, 2019, 11:47:05 AM »
And please! Use github for reporting issues. There will gonna be a mess here soon and difficult to track.

33
Themes / Re: Ambience HD theme v0.7 beta [Released]
« on: November 30, 2019, 11:44:23 AM »
if ArcadeFlow's shaders comply with the GLSL 1.10 specs it will run, I'm using GLSL 1.30
I could in theory downgrade it to GLSL 1.10, but I don't have any platform to test it on atm.

This is also the reason why it does not run on older Macs. I'll have to think about it.

34
Themes / Re: Ambience HD theme v0.7 beta [Released]
« on: November 30, 2019, 11:35:44 AM »
What platform are you running it on?

35
Themes / Re: Ambience HD theme v0.7 beta [Released]
« on: November 30, 2019, 11:27:29 AM »
This is what it looks like for me
Attract master-git, OS Linux,
AMD RAVEN APU
1920x1080
everything else works fine

Ambience HD is heavy on OpenGL shaders, it does not support GLES. Try building AM without GLES
you can check the shader language version by launching attract -v

36
Themes / Re: Ambience HD theme v0.7 beta [Released]
« on: November 30, 2019, 11:23:22 AM »
After I change the theme I get this image and does not load the new theme, I already installed the AM 2.6 but still continue to receive the same screen, could someone help me? Other themes work normally.

run
Code: [Select]
attract-console --loglevel debug >log.txt and attach the log.txt to your post

37
Themes / Re: Ambience HD theme v0.7 beta [Released]
« on: November 30, 2019, 10:41:54 AM »
I've decided to drop the scrolling because it wasn't showing full titles on inactive tiles.
The only thing I'm wondering about is why it isn't showing the full title on your machine



What is your screen resolution?

38
Themes / Re: Ambience HD theme v0.7 beta [Released]
« on: November 30, 2019, 10:09:30 AM »
thanks bro,   it looks great,  cant wait to try it...thanks

edit couldn't wait....dam this is sweet...the alphabet animation is classy  working
great for me...! 

Q: after some others have a chance to mess with it could you let me know how to add other things to the menu
like in the video "arcade" puzzle ext...  thanks,   

These are just filters, You add them here:


39
Themes / Re: Ambience HD theme V0.7 beta RELEASED
« on: November 29, 2019, 08:18:17 PM »

40
Themes / Re: Ambience HD theme [WIP]
« on: November 27, 2019, 04:46:34 PM »
Testing it on my cab. No issues so far.
https://youtu.be/2lT_oY1BfX0


Sorry for the quality, I did't have screen cap set up.

41
Themes / Re: Ambience HD theme [WIP]
« on: November 27, 2019, 02:09:45 PM »
Just a little update:

I'm digging through those 4000 lines of code. Fixed 90% of things that needed fixing, just 2 bugs left to squash and I'm ready to publish the first beta, so it shouldn't be long.


42
General / Re: AM freeze at first start up
« on: November 24, 2019, 02:31:14 AM »
If it's freezing only in AM 2.6.0 it may be related to this commit
https://github.com/mickelson/attract/issues/566

43
General / Video flags fix - test build
« on: November 23, 2019, 04:19:20 PM »
I need your advice regarding the video_flags fix I'm preparing.
Currently when you exit an emulator videos always restart regardless of the video_flags  (Vid.NoAutoStart is ignored), or video_playing property
I fixed that, but I'm unsure what to do with the videos that had set video_playing = true/false before launching an emulator

I've also fixed a stalled frame showing for 5 frames after you exit the emulator and before the video restarts.

There are 2 undecided video states (playing/stopped) when you exit an emulator with the following properties set before launching a game:
Code: [Select]
Vid.Default & video_playing = false -> ?
Vid.NoAutoStart & video_playing = true -> ?

With my fix video_playing is ignored and video playing state relies solely on video_flags when you exit a game.
Should I check video_playing property and use video_flags only when you load another video snap, or leave it as it is?

https://1drv.ms/u/s!Ag7uFeM0f_fzh9IpRmCwD9qGJzrwfw?e=C1qS8y

The archive from the link contains Attract Mode executable and a layout for testing.

You may want to misspell the emulator exe in settings so the game does not launch, preventing the resolution switching from masking stalled frames.

44
Themes / Re: Ambience HD theme [WIP]
« on: November 21, 2019, 06:30:11 AM »
Hi.
Since there is still a lot of interest in that theme I could spare some time to finish it to shareable state. The only problem I found today is that Attract Mode 2.6.0 broke Ambience. AM will be crashing on loading Ambience until the regression described here https://github.com/mickelson/attract/issues/566 gets a fix

45
General / Re: Attract Mode test build with improved video rendering
« on: March 12, 2019, 04:49:01 PM »
I forgot to mention. You will see the quality improvement if your movies were recorded in their native resolutions ie. Progetto snaps for Mame

Pages: 1 2 [3] 4 5 ... 21