Recent Posts

Pages: [1] 2 3 ... 10
1
Scripting / Re: Sound on Button Push
« Last post by FrizzleFried on Today at 12:59:15 PM »
Using the 2nd code you posted (directly above)... I now get the click when I push CUSTOM1 (button)... unfortunately the animation (CUSTOM1 is associated with moving from the "LIST" screen to the "INFO" screen to the "FLYER" screen then to the "CABINET" screen and then back again.  Now it just... clicks.  :)

Is it perhaps WHERE I put the code that makes the difference?

THANK YOU!!

EDIT:
Figured it out.  All I needed to do was change the first "return true;" to "return false;"...

:)

Thanks!
2
I am using AM ver 2.3. Also, I can confirm that command works!

Interestingly enough, I bricked my HDD and had to reinstall everything last night. After everything was back up and running, I tried the command and it worked perfectly. I haven't run all the Windows updates on the restore. I have only installed the roll-up update pack and essential files (.Net, Visual C++, drivers). Perhaps Windows Updates is causing some conflict. But it works now without any work-arounds. Thanks!
3
The command I posted does work. It points attract to the config directory. It does not hide the console like you think? I’m so confused now as to what you are trying to do and have already done.

I am just trying to shell directly to AM properly. I achieved it by shelling to the batch file, but that leaves the batch file command window visible. I want to get rid of that. Just straight shell to AM.

I am sure that command works, it just doesn't work on this build I am working on. What's happening now is that Attract Mode doesn't even launch upon bootup entering that command from the registry. I'll pass on figuring it out for now as the BATCH-to-EXE work-around works. And so look towards the next build using that command and report back.

What build are you using?

You shouldn’t need to use a batch file. I’ve been shelling attract from registry for a few years now. The -c param will resolve config issues in most cases. Attract 2.1 has two separate builds, with and without command line. I also have an ahk script/app I made to hide the attract console and pass params. Can find it in the plug-ins sticky. Obsolete now.
4
Scripting / Re: Sound on Button Push
« Last post by calle81 on Today at 01:07:21 AM »
Otherwise this should work:


fe.add_signal_handler(this, "on_signalinfo");
function on_signalinfo(signal) {
   if ( signal == "custom1" ){
      local Wheelclick = fe.add_sound("selection.mp3")
           Wheelclick.playing=true
      return true;
   }
   return false;
}
5
Scripting / Re: Sound on Button Push
« Last post by calle81 on Today at 12:51:10 AM »
I think what you do might trigger Transition.ToNewList:

////////////////
//Sound effects
////////////
function fade_transitions( ttype, var, ttime ) {
 switch ( ttype ) {
  case Transition.ToNewSelection:
   local Wheelclick = fe.add_sound("Click.mp3")
         Wheelclick.playing=true
  break;
  case Transition.ToGame:
  case Transition.ToNewList:
   local Wheelclick = fe.add_sound("selection.mp3")
         Wheelclick.playing=true
  break;
  }
 return false;
}
6
General / Re: InstantSheller in Win7 - Need to Hide Batch Command Prompt
« Last post by albert_c on Yesterday at 08:20:42 PM »
The command I posted does work. It points attract to the config directory. It does not hide the console like you think? I’m so confused now as to what you are trying to do and have already done.

I am just trying to shell directly to AM properly. I achieved it by shelling to the batch file, but that leaves the batch file command window visible. I want to get rid of that. Just straight shell to AM.

I am sure that command works, it just doesn't work on this build I am working on. What's happening now is that Attract Mode doesn't even launch upon bootup entering that command from the registry. I'll pass on figuring it out for now as the BATCH-to-EXE work-around works. And so look towards the next build using that command and report back.
7
General / Re: InstantSheller in Win7 - Need to Hide Batch Command Prompt
« Last post by keilmillerjr on Yesterday at 07:48:09 PM »
The command I posted does work. It points attract to the config directory. It does not hide the console like you think? I’m so confused now as to what you are trying to do and have already done.
8
General / Re: InstantSheller in Win7 - Need to Hide Batch Command Prompt
« Last post by albert_c on Yesterday at 04:10:13 PM »
Burrrr, so I did get it to work as desired with the BAT-to-EXE converter posted earlier by @hermine.potter. Now the command console does not appear just before AM loads. AM launches fine. I checked to make sure that focus wasn't stolen after launching a few games. Seems to be all good and accomplishes what I set out to do. Should be noted that I can set InstantSheller to shell to the exe I created, or works by making the registry change manually.

But but but but, adding in this entry to the registry didn't work for me at all:

C:\Attract Mode\attract.exe -c C:\Attract Mode

Wasn't from a lack of trying either. Trying from normal Windows Explorer after undoing changes from InstantSheller didn't work. Tried it without the 'C:\Attract Mode' suffix at the end of the entry, and with it. With the backslash at the end and without it. With quotations, without them. Made the changes after using InstantSheller and bringing up regedit. Typed in the entry precisely, copied the directory and exe file name from the properties menu and explorer bar even. Nothing worked with this entry. Not very fun doing this on a CGA 15khz arcade monitor, I might add.

Perhaps my installation of Windows for this build has been flumoxed with enough where this would not work any longer. So I'll save investigating getting shelling to work using that registry entry for the next build which will be sometime next week.
9
Themes / Re: Vertical CRT layout 0.2
« Last post by markc74 on Yesterday at 02:54:08 PM »
Oops. Overwrote my last post when I meant to edit it... anyway - the crux was:

- ace to see it on a CRT - I like what you've done with it
- I officially give it to the forum to own
- I'll probably create a horizontal version at some point for my other cab but I'll see if anyone else fixes the bugs first  ;D
10
Themes / Re: Vertical CRT layout 0.2
« Last post by FrizzleFried on Yesterday at 02:44:46 PM »
Certainly understandable and I do appreciate the work you put in to it... if anyone can chime in on how to either add scrolling to the HISTORY component ... or pagination (as mentioned... though I think this might be actually harder to implement)... please let me know.

Pages: [1] 2 3 ... 10